Base station: which message contains the corrections?

I have my base station set up following the instructions here. I am using Survey-in mode and can see the survey complete successfully by watching the SVIN message. Following this I expected to see some new message appear which contains the corrections, but I am not. Which message contains the corrections and how do I request it?

As an aside: Under configure -> Messages, I am unable to request RTCM1127 using u-center 8.22. When I try to select this message from the drop down box it won’t allow me. Could this be why I’m not seeing corrections?

Thanks for your help,

Nate

1 Like

Dear Nate,

The messages containing corrections are :

  • RTCM 1005 (contains base location)
  • RTCM 1077 (contains GPS raw data)
  • RTCM 1087 (contains GLONASS raw data)

Make sure you activated these messages in View -> Configuration View -> MSG (Messages) and that you saved Configuration. Once Survey-In mode is finished, you should see those messages in Messages View.

Please tell me if that solves your issue.

Kevin

Kevin,

Thank you for your help. I just tested again and have confirmed I do not see the RTCM messages in message view. I have

  • Enabled the RTCM messages on both USB and UART1
  • Saved the configuration. When I disconnect then reconect from u-center I see the messages are still enabled on UART1 and USB.
  • Completed the survey in.

I still do not see RTCM messages. Screen shot of u-center attached.

Nate

As an additional data point, I repeated the instructions on my second M8P-2-10 and got the same results.

Nate,

Can you make sure you are looking at messages under RTCM3 tab? It looks like you are under UBX -> RXM -> RTCM. This message is to monitor RTCM reception on rover side. You should check there :

Interesting. I do have the RTCM3 option but it is not expandable like yours is. I downloaded u-center 8.22 here. Do I need to do something special for it to understand the RTCM messages?

I have exactly the same version. Could you please record a file by pushing the red circular button on the toolbar? Just record for a couple of minutes and send it to me.

Certainly. What is the best way to send you the file? The forum will not let me upload the .ubx file. I did have an error message pop up when trying to save the configuration.

I just sent you my email by PM.

I see no RTCM messages. It looks like Survey-in has not worked successfully, even if it says so. Can you re-try it with the following parameters :

  • Observation time : 180 s
  • Position accuracy : 3 m

Keep in mind that if you save this configuration the board will re-enter Survey-in mode at each start up. You can also try with Fixed Mode (instead of Survey-in) by entering a known position and see if the RTCM messages are generated. Also make sure you are using M8P-2.

Using the recommended settings the survey completed in 323 seconds. Still no RTCM3 messages.

I also tried using a fixed mode under Configure -> TMODE3, entering my estimated lat, long, alt and 1 meter for accuracy. Following this my SVIN status was ‘Not started yet’, and still no RTCM3 messages. Could I need to update firmware on the GPS module?

I am certain I am using the M8P-2. I tried to survey-in on the M8P-0 and it will not even start the survey.

I found the solution to my problem. Under Configure -> PRT I needed to set the USB to send RTCM3.

Now I see RTCM3 messages enabled in message view. However, I am unable to view the data itself. Is this normal?

Great! I should have thought of that, sorry. I will add it to the documentation :slight_smile:
Yes it si normal that you do not see the content of the message. Now you should try to send corrections to rover and see if the red LED turns on :

  • blinking -> float solution
  • fixed -> fix solution

Thanks for your help. I was able to get both RTK float and RTK fixed precision last night. Very impressive!

Are there any UBX messages with information on whether the receiver is in float or fixed mode? The NMEA GNGGA message has a flag which indicates this, but my autopilot only contains a UBX parser and I don’t want to deal with adding a NMEA parser as well.

The closest I can find is the UBX Status message, which has a flag for DGPS fix. It is set to 1 when I have both fixed and float precision though, so it does not help me distinguish between the two.

Good!

The most complete message is UBX-NAV-PVT, it contains position, velocity, time, heading and accuracies (everything an autopilot needs to fly). In the addendum to ubx procotol, they have added a bitfield in this message (previously reserved, so driver modification is minor) to check whether the position is float or fix.

Have a look at pages 48-49-50, bitfield “flags” :

1 Like

Now I’m having difficulty getting the base station to send RTCM3 messages to Mission Planner. The problem seems to be that setting the USB port protocol to RTCM3 does not persist.

I select both protocol in and protocol out to be RTCM3. I then write the configuration as detailed in the instructions. If I power cycle the GPS receiver the RTCM3 setting is gone and I must re-do it.

Setting the protocol in and out to be RTCM3 on UART1 does not have this problem. It persists through power cycles.

I was able to get a temporary solution working by using the base station’s telemetry port along with an FTDI cable. Still no luck with RTCM3 messages from the USB port, though.

Could you maybe try to update the receiver? To do so :

  • download latest firmware from here and unzip it. Connect your board to U-Center.
  • click on Tools -> Firmware Update :

  • then select a firmware image (be careful when choosing M8P-0 or M8P-2). Leave flash definition empty and locate the FIS file (it is inside your U-Center installation folder).

  • then flash the board, you should see this screen :

No luck. I still see the same problem.