Can`t get RM3100 magnetometer to show it self

Got my first Pixhawk now and trying to get it to work. (Pixhawk 3Pro - F9P Sirius RTK Rover - F9P Sirius RTK Base - RM3100 Magnetometer )

Im starting with on bench setup and i sure need some help to understand something regarding the RM3100 external compass i bought.

I have the SIRIUS RTK rover WITHOUT the compass embedded so we are running the external Drotek RM3100 unit.

I am very new to the whole Pixhawk setup so please bear with me :slight_smile:

The RM3100- i connected with the I2C port to the Pixhawk 3Pro, but it is not showing up in Ardupilot .
I only get the ID from the two internal Pixhak 3 magnetometers- showing ID 1 and 2 and 3 has no ID.

What is it that i need to do to make it talk to each other ? what to change so it shows up.

Thanks :slight_smile:

Hi there,

The RM3100 is usually simply connected to one of the I2C port available on the Pixhawk 3 Pro, then try to reboot the whole device and normally it should work.

What is the test procedure you tried? How did you get confirmation that the RM3100 is not working? Did you update the Ardupilot firmware? Have you tested using PX4 firmware instead of Ardupilot?

By using the mavlink console which is available in QGroundControl and typing in sensors status, do you manage to see the RM3100 mag? Does anything show up in the mavlink console when typing RM3100 info ?

Here, i have attached some valuable information on RM3100 for your reference.

https://drotek.gitbook.io/additional-devices/sensors/geomagnetic-sensor/rm3100

I hope this helps.

Thank you and have a nice day.

I basically just plugged the RM3100 to the I2C port on the Pixhawk 3pro and then i have connected it to pc.
I have now tried using Ardupilot as well as PX4. When i look at the list i only get Compass id 1 and 2 in Ardupilot and 0 and 1 in PX4. To double check that it is not the RM3100 id i am seeing , i did the same without having the 3100 connected. and the id is the same ( so i guess that is the two internal ones in Pixhawk 3 )

I do not have a confirmation that the RM3100 is not working- im hoping that for some reason there is only lack off comunication between the two units.

When i ran the PX4 i just installed the PX4 firmware suggested by the setup and ran with that .
I was not able to figure out how to find the RM3100 in the Mavlink console.

Any more guides to get them speaking to each other is highly appreciated :slight_smile:

And again- Bear in mind that all off this is new to me. so step by step is super helpful.

Also if there is a way to eliminate a Faulty unit. that would be sweet as well.

Hi there,

If you believe there is an issue with this device, please open a ticket here: https://drotek.com/contact-drotek/after-sale-service

We can discuss further and fix the issue. Please do mention the โ€˜Order IDโ€™ of the items.

Thank you

Hi again.
i now loaded Copter V4.03 to the Pro3 unit.
Still no auto detect and i am then courious - Do i need to go and change some data in the Parameter tree ? Like settings of Serial ports ? 4-5-6. Do i need to set BAUD - OPTIONS - PROTOCOL to get it to detect the RM3100 ?