Can't see the RTK Mode, it is always in 3D!

Hi. We have two Tiny RTK module to get high precision global positioning for our unmanned surface(sea) vehicle project. Unfortunately, we didn’t manage the rover side. We tried the modules with making the telemetry connection via wires.
First, we configured the base side as what Drotek Documentation says. We opened the necessary RTCM3 messages. Then, we start a survey-in and successfully finished it. After that, base module fixed mode turn on TİME as expected. At the end, we sent the RTCM3 messages through the UART1 link which is connected to the rover side telemetry link serially.
Then, for the rover side again we configure the module as following Drotek Docs and when we opened the messages view to see there was any RTCM3 messages, we saw the RTCM3 messages that we sent. Although we sent the RTCM3 messages to rover side successfully, our rover side fixed mode didn’t turn on RTK mode. It is still in 3D fixed mode. Rarely our rover side turns DGNNS mode but then again it goes back 3D fixed mode .
By the way, this was for test to run the modules. In project, we will use this modules with 5.8Ghz wireless channel. We set up everything for this wireless channel for sending rtcm3 messages correctly from base to rover. However we want to see that it works in RTK module with wire connection for telemetry.

  1. I saw that a solder bridge topic in the forum. May it be problem ?
  2. How much antennas must be away from each other ?
  3. Wire connection can cause any problem ?

What should we do to make it right and work?