Community forums

Capteur de courant valeur fausse

Bonjour, j’ai un petit problème avec la nouvelle carte que je vous est commandé récemment.

J’ai rentré les valeurs dans MP pour le calibrage des sensors pour tension et courant mais seul la tension et correct.

La valeur du courant est de 24A au repos et si je modifie les valeurs je me retrouve avec 0.8A mais qui reste fixe.

Je vous joint deux photos pour vous montrer.

Cdt

Bonjour,

Avez vous armé la Dropix? Ca doit être un bug de Mission Planner.

Oui elle est armé mais j’ai le meme affichage dans l’OSD.
Vous parlez de beug dans MP, votre Dropix est tout aussi optimisé pour MP/Ardu ou plutôt pour QGC/PX4?

La Dropix est l’équivalent de la Pixhawk 1 donc designée autant pour Ardupilot que PX4.
Pour savoir si ce n’est pas un bug d’Ardupilot il faut mesurer directement la tension en sortie du capteur de courant. Tenez moi au courant.

J’ai regardé comment fonctionner le principe de la mesure de courant par résistance de shunt.
Il suffit de mesurer la chute de tension à ses bornes et d’utiliser (dans le principe) la loi d’ohm.

Sur la board de distribution, le petit pad cuivré je l’est relié avec un fil au pad nommer i-sens de la board principal. Rien d’autre à faire? J’ai trouvé la manipulation sur un forum mais rien sur votre site, c’est normal?

Autre chose, quelle est la valeur en ohm du shunt?
J’utilise une batterie en 6S, quelle est la valeur de la tension que je doit trouver au borne du shunt ou de la Pin C?

Oui c’est bien ca. Je pense que la tension à la sortie C doit être environ de 0 lorsque les moteurs sont à l’arrêt. Cette valeur doit augmenter au fur à mesure que les moteurs tournent.
Pouvez vous faire un test svp?

quand les moteur ne tournent pas j’ai 477mV et sa monte à 580 quelques soit ensuite la position du manche des gaz.

Vous pouvez me montrez la manière pour raccorder le I-sens? (photo, schéma, etc …)

N’ayant pas trouvé de schéma sur votre site je ne suis pas du tout sur de ce que j’ai fait.

Il faut relier la carte de régulation à la carte de puissance par 3 fils.
Il y a le + et le -. Ensuite reste le fil qui va entre le pad I_sens (le bottom de la carte de régulation) et le pad sur le top de la carte de puissance.
J’espère que c’est plus clair maintenant.

Plus clair effectivement, j’ai trouvé que vous utilisiez le INA139 pour la mesure sa va me permettre de mieux comprendre le principe et relever les tensions.

Sur votre shunt il est noté 0m25, sa donne quelle valeur en ohms?

J’ai trouvé le datasheet du INA139, sa ma permis de lever le doute sur mon câblage qui est bon.

Je n’est aucune chute de tension au borne de la résistance de shunt je l’est donc déssoudé et mesuré

avec un ohmmètre et je trouve 0 ohms donc un cours circuit franc (un fil). Je pense avoir trouvé le problème.

Vous me confirmez bien que la résistance fait 0.25 ohms? Ou puis je trouver la même?

Je viens de penser que je vous est envoyé semaine dernière une carte Dropix en SAV (problème I2C).

Auriez vous la possibilité de me retourner une résistance en même temps que la carte?

250 µOhms

Vous me faite douter là, 0,25 ohms font bien 250 µOhms ?

Attention vous confondez mOhms avec µOhms!!

Au temps pour moi.

Sur l’an broche 1 de l’INA139 je dois relever quelle plage de tension entre zéro et plein gaz?

Je fait une parenthèse, est ce que votre module de puissance pro fonctionne que avec la Dropix ou est ce que l’on peu l’utiliser avec une carte Pixhawk 1 ou 2 ou Pixhawk Cube?

Notre power module pro a été designé pour la Dropix mais peut être connecté à n’importe quel autopilote compatible PX4/Ardupilot.
Il y aura sûrement des modifications de câbles à effectuer.

Je vous remercie.

Je me permet de vous reposez la question, la Dropix est elle tout aussi fonctionnel sous MP\Arduplane quelle l’est sous QGC/PX4?

oui entièrement!