Connecting the RTK base to mission planner via telemetry

Hello, I was trying to figure out if you can connect the base from the Pixhawk 3 PRO ready RTK GNSS Kit (F9P) kit to a computer with mission planner using telemetry? If I use the USB connection I am about to connect and see satellites just fine but I was looking to have the base set up further away from the computer then I would like to try and run a USB cable. When I try it says connected but I never see any data or satellites. Any help would be appreciated.

Hi there,

Can you please provide a demonstration using pictures or a diagram so that it ll be clear to find a solution for your test?

Best Regards,

The usb cord works to connect to the computer but I would like the telemetry radio to work so I can place the RTK base further away from the computer for a better signal without the interference from being next to a building

Hi there,

If I understand correctly, you wish to get connected to the base from a distance.
How are you planning to power the RTK Base? Also, to view the satellites, you need u-center.

Here, I have attached our online documentation to try with the NTRIP protocol where it requires a rover.
https://drotek.gitbook.io/rtk-f9p-positioning-solutions/tutorials/setup-rtk-solution-using-a-local-network

Here, I have attached an online documentation of ‘Pixhawk 3 Pro integration’ that will assist you to accomplish your goal.
https://drotek.gitbook.io/rtk-f9p-positioning-solutions/how-to-get-started/plug-to-your-pixhawk-3-pro

Best Regards,

It will be powered by battery/solar

I can see that it is connected with the USB but when I followed the guidelines on your site for the telemetry I am unable to see any indication that I am receiving data from the RTK base

Hi there,

So you have tried the online guidlines on configuring a telemetry as added here: https://drotek.gitbook.io/rtk-positioning-solutions/the-telemetry-system/configuring-telemetry-for-rtk-1

Best Regards,

I have. I configured 2 radios.They work when used between the computer and the pixhawk so I know they are working as a pair. When I connect them between the computer and the RTK base the computer says connected but no data comes up on the screen. Its like the radios see each other but have nothing to pass between them. Maybe the TX and RX pins on the cable that came with them need changed around?

Thank you for helping me with this.

Hi there,

Yes, you’re right! The Tx and Rx on the Pixhawk is not necessarily the same as the RTK Base and it depends on which serial port you use. Therefore if you are connected with the JST-GH 6 pins cable, you can swap the Tx and Rx.
This may resolve your issue.

I have added the link of the Pinout documentation of the Pixhawk and RTK Base for your reference:
https://drotek.gitbook.io/pixhawk-3-pro/hardware/inputs-outputs
https://drotek.gitbook.io/rtk-f9p-positioning-solutions/rtk-f9p-drotek-modules/sirius-rtk-gnss-base-f9p/hardware/pinouts

Best Regards,

I tried with the tx and rx swapped… still a no go.

On the RTK base witch of the 2 GH connectors should I be using?

In the pin out picture from your link I had been using the top one but also did try the bottom one

Hi there,

I have added the pinouts of the SIRIUS RTK GNSS Base here:

You can use Uart 1 directly or Uart 2 swapped. You may need to find a way on how to transmit RTCM data from the computer to the base using telemetry.

I was able to get the u-center to connect after re-flashing all the radios and the base and starting fresh with the TX and RX pins swapped using uart 1.

Now that I got it working in u-center. when I try to connect to the same port in mission planner I get an input signal with a rate I can see changing slightly as well as messages sent. but I am unable to see that I have connected to any satellites and the bars that usually show them are not there. Would you have any recommendations on how to get this to work like it does in u-center?