Décalage du compas

Bonjour,

J’ai un décalage important au niveau de mon compas qui varie de 0 à 90°.

Ma configuration :

Dropix v2
GPS version Mushroom
Télémétrie 433
Capteur de tension à effet hall Drotek.

J’ai déjà monté des multirotors avec des Dropix v2 avec une configuration semblable à celle qui est présentée ci-dessus et ça fonctionne bien.

Là, je travaille sur un Rover 4 roues avec une direction conventionnelle. J’ai monté le contrôleur et ses périphériques dans une boite en plastique. Lors des paramétrages du contrôleur, ce dernier n’est pas installé sur le rover, mais dans sa boite en plastique, à côté de mon PC pour pouvoir réaliser plus facilement les calibrations.

Comme je l’ai écrit en introduction, j’ai un décalage important au niveau de mon compas qui varie de 0 à 90°. J’ai une autre antenne GPS d’avance que j’ai essayé et j’ai toujours le même problème. J’ai ce décalage avant même que le contrôleur soit installé sur le rover.

Ca fait des heures que je cherche une solution, mais je ne trouve pas. J’ai même posé à côté de mon antenne GPS une boussole basique pour voir s’il y avait un décalage, mais rien.

Pouvez-vous m’aider ?

Dorian

Bonjour,

Je précise que j’avais essayé cette configuration auparavant avec un Pixhawk chinois (pas cher pour faire des tests) et cela fonctionnait.
J’ai ensuite découvert le Dropix et ai pu constater les qualités du produit, c’est pour cela que je souhaite l’utiliser sur ce rover.

Dorian

Bonjour,

J’ai fait de nouveaux essais.
Quand je débranche mon antenne GPS (Mushroom) et que je refais une calibration du compas, l’erreur descend à environ 8°.
J’ai aussi fait des essais en téléchargent le firmware d’un multirotor (ce que j’utilise habituellement) et ça n’a rien changé.

J’ai démonté le Dropix et installé le Pixhawk Chinois que j’avais et ça fonctionne.

Je souhaiterais avoir de l’aide, car c’est un produit que je souhaite produire et proposer à l’avenir à mes clients, et je préfèrerais installer un Dropix plutôt qu’un produit bas de gamme.

Dorian

Salut,
je ne comprends pas bien ce que tu entends pour décalage du compas .

Aussi quand tu parles de 8° d’erreur sans Gps mushroom branché tu veux dire qu’en pointant vers le nord ta Dropix la direction affichée est 352° ou 8° ?

As tu fait correctement la calibration des accellerometres ?
Quand tu branches la batterie est que la Dropix est bien immobile dans les secondes après ?

Bonjour,

Désolé pour cette réponse tardive, mais Drotek m’a répondu
par mail et solutionné mon problème. J’ai bêtement oublié de modifier le
paramètre « rotation roll 180° » du compas.

Ce que je ne comprenais pas, c’est que les valeurs du compas
n’arrêtaient pas de variées alors que je ne bougeais pas mon appareil. J’imagine
que du fait du mauvais paramétrage, il y avait un conflit entre le compas du
Dropix et celui de l’antenne externe.

Ce n’est pourtant pas le premier appareil que je monte avec
un Dropix, mais bon, là, je suis passé à
côté.

En tout cas, merci à Drotek pour leur réponse.

Réponse de Drotek :

Avez vous bien configuré la dropix en suivant ce tutoriel (attention
à bien mettre “rotation roll 180” pour le compas externe)

Une petite précision supplémentaire par rapport à ce
qui est écrit dans le tutoriel: lors de la calibration du compas, il ne faut
pas tourner dans “tous les sens” mais il faut:

  • commencer la calibration avec la Dropix qui pointe
    sur le nord,

  • faire une rotation complète sur l’axe pitch,

  • tourner la carte de 90° sur le yaw

  • enfin, faire une rotation complète sur l’axe roll.

Bien sûr, lors de cette étape le GPS doit être
solidaire de la Dropix et pointer dans la même direction que celle ci.