DP0601 RTK GNSS (XL F9P) fix failure

DP0601 RTK GNSS (XL F9P) we’re trying to interface this module(that is using the ZED-F9P) with the compunter via USB. Using U-center we can’t get a fix only the coordinates. What are the propper settings to get a fix on the ZED F9P module?

Hi there,

You can follow our useful link to get started with this device: https://drotek.gitbook.io/rtk-f9p-positioning-solutions/rtk-f9p-drotek-modules/dp0601.
You probably want to try with the survey-In of 120 seconds minimum observation limit and a position accuracy limit of 3 metres. (Message view >>UBX>>CFG>> Time mode3).

I hope this helps. Thank you.

do you also have tutorial for a moving base configuration?

in this post DP0601 as a moving base from a year ago I saw that you were also tested this with this module.

Hi there,

We don’t have a turoial per say, but I can explain how to perform the test for the moving base configuration.

So to get the heading value between your moving base and the rover :

First go to here : https://github.com/u-blox/ublox-C099_F9P-uCS 9
Then download the whole folder (Upper right green tab “Download”)
Then you need to configure your “Moving base” (that actually can be either static or moving during the mission) using the file F9P Base moving base config C99.txt located in ublox-C099_F9P-uCS/zed-f9p
Finally, configure the rover using the file called F9P Rover config C99.txt located in the same folder
Now you should be able to get some values under the RELPOSNED ( registry from the Rover of the Heading and baseline length.

The survey-In is disabled as we are interested in the relative positioning and the position of the Base is constantly moving.

We are still strugeling, is there a possibility we could contact eachother via stream so we can debug the problem right then and there?

resultsf11 ![f12|356x480]

f12

Hi there,

I’m sorry to hear that you are having issues with the setup up.

  1. You can try again by first setting up both the moving base and rover to default configuration and then upload their respective configuration files.
    ucenter_default_config

  2. Ensure the RTCM correction data is flowing to the rover. What is the mode of your communication link between the base and the rover? Is it via a JST-GH cable or telemetry? Can you please send a picture or you can send a video of the entire procedure? You can check the RTCM status as shown below:

In addition, if you wish to attain any product support, kindly follow the link: https://store-drotek.com/915-online-product-support.html

Best Regards,

https://youtu.be/YGA4gF7-_0c

We used some ground planes and it seemes to work.

There are only two things left to figure out:

  • As you might have noticed, the update rate of the heading was quite slow. Is there a way to increase this rate??
  • The message we recieve via the com port, doesn’t include the heading any idea howe we can include the heading in this message?

Hi there,

MSM7 messages that is required for moving base configuration can be correctly stored on the module and verified via ucenter as shown below:
Configuration View (Ctrl+F9) >> UBX >> CFG (Config) >> MSG (Messages)


(Depends on which UART port you wish to use)

The heading can be displayed directly from RELPOSNED interface on u-center
Message View (F9) >> UBX >> NAV (Navigation) >> RELPOSNED (Relative Position NED)

In terms of attempting to increase the data rate, please refer to this post F9P logging issue

Best Regards,