Drotek coms module baudrate

Hi

I have a setup with 2 M8P RTK (DP0503) and they are connected via a Drotek coms kit (see link).

The rover module does not receive RTCM3 messages. The RTK base sends the RTCM3 messages 1005 and 1077.

The green LED on the coms module is permanent ON - so the coms link between base and rover is ok.

What is the correct baud rate to used together with this coms module ? Current 9600 baud is used but it does not seems to work.

Can I connect the base telematic and the rover telematic com ports with the standard cable - to test this part of the link without problems ?

Best regards, Erik

Hi,

Please follow this guide to see the parameters stored into the memory then can you give me what’s in the “Baud” text box for both devices.

https://drotek.gitbook.io/rtk-positioning-solutions/the-telemetry-system/configuring-telemetry-for-rtk-1

If it is written “38” then choose 38400 bauds as working baudrates in the M8P settings for both the base and rover (use u-center).

To wire connect both the base and rover you need to twist Rx/Tx pins

Hi Paul

Thanks for the feedback.

Is there a way how I can bring the module, back to default setings - via
reset pin or similar ?

Best regards, Erik

You can do it from the 3DR software interface in the link I previously provided to you : https://drotek.gitbook.io/rtk-positioning-solutions/the-telemetry-system/configuring-telemetry-for-rtk-1

There is a TAB “Reset to Defaults”