Drotek GPS+Compass XXL (new) - not working

Hi everyone!

I’m going crazy here, I have used two different gps modules + compass before and I had solid position lock, may be not as many sats.

Now about 4 month ago I got my unit from Drotek… it was giving me hard time when I “tried it on”.

  • installed flat forward for test only
  • set it 180 roll
  • test
  • almost crashed after switching to loiter, saved it with stabilize mode (non GPS mode)

After that day (it was in Jan 2017) I was busy and let it sit thinking that it was my lack of proper set up.

But…
Last 4 days I was testing it and trying to get it to work

  1. Stabilize is very stable
  2. Alt hold - it can Hoover in one spot for almost a minute before drifting
  3. No oscillations
  4. 3-leaf prop produce less vibes than any 2 leaf best balanced props
  5. Constant compass errors
  6. Even if I turn off 2nd compass (internal), than calibrate the first compass (Drotek), it won’t point to north (will look 30’ off after reboot it may become 50’ and after reboot 180’)
  7. Orientation is correct because during calibration both spin around same axis and on the same side, and they spin in the same direction (for example spins over red side of x, in direction from green Y to blue Y)
  8. Right after calibration (of both compasses) they still may point not at the north but 20’-40’ off
  9. There is only UHF on board and 433 telemetry
  10. Before I also had 1.3ghz video tx and everything worked with old gps/compass module
  11. Disconnecting Telemetry has no effect
  12. Battery on top also was there with old no name GPS and it was working really well
  • my motor mounts are perfectly flat with the frame (it is a common problem with round tubes that creates toilet bowl for example)

How does it look like?

  • when gps mode engaged copter sometimes imidiately sometimes a second later shoots out to a rendom direction. It is not a graduate increase in circles (toilet bowl).
  • I start to wonder if my gps/compass is faulty, because even being so far on the mast, with only uhf on board (no telemetry, no Pi3, no Gimbal, no vTX, nothing to create interference)

------------ My last thoughts -----------

  1. Move battery bellow
  2. Remove metal mast (even thou gps is on hot glue to the CF plate that is hot glued to metal mast), and sub it with CF mast
  3. Pray

Hello,

Can you also add a picture of the autopilot, how is it oriented in comparison with the arrow on the GPS module?

Autopilot is oriented strait, normal way. It’s inside the frame

------ update-------

I have moved the battery bellow the frame and tried everything possible and still compas is acting strange… its constantly off. Let say I see it off by -90, so I change orientation from roll180, yaw 270 (which supposed to be correct) to roll 180 and calibrate, no compas can be ok or off again. However after some moving around in my hands it Its off again! Drifts on its own it seems.

I did a flight to log it, will upload it tomorrow

Sorry I didn’t get whether the autopilot is oriented parallel to GPS arrow or perpendicular.

God unit arrow left
Autopilot arrow forward

So I set Compass 1 180roll and 270 yaw

Can you try having GPS and autopilot’s arrows facing the same direction and then try with ROTATION_ROLL_180?

Bonjour,
Puis-je utiliser les modules GPS+compas sur mon contrôleur SP racing F3 ?

looks like your gps is rotated by 90° if the flight controller is oriented at 0° , i mean with heading front

Hi, so I installed it simple front - front and made it 180 roll. Did onboard compas calibration at strict mode. Made compas motor compensation (very low values I think, not sure. Will attach it here in 10min).

Result

  • compas now is better looks the same direction, gets upset for no reason by 15’ at most but learning brings offset back to proper direction.

  • one of the major problem was manually set declaration! I set it properly for my exact location (used the link in Mission Planner), but with auto Compass direction is better!.. Confused, but what ever.

  • I can leave sticks for 3-4 mins in no wind condition in altHold mode it would not drift further than 3-4m, holds position better than Loiter :slight_smile:

  • loiter with standard XY P and I (PIDs) of 1.000 and 0.500 goes crazy, and reaches a 4m diantre circling in 10 sec! If I lower everything down to minimal, and leave XY P stabilization at 1.000 than circles stay small gradually increasing and decreasing. q

  • I get a lot of Velocity Varience every time I speed to any direction.

  • GPS throughs copter further along the flight, after i break (like GPs overshoot…), and that is while having 16-18sats and hDop of .6-.7!

  • altitude holds super well (Mavic level well)

I did, and results are now in the comment above… Don’t get why it behaves this way. Compass is def ok now. Power sensor calculates the current with .2A accuracy (compared to my multimeter being connected in line) so compas mot is accurate and showed low level of noise. Will attach screen shots later.

My last hope is that gps soft ware needs settings to be altered… Does any one have good loiter gps settings?

Can you please send me an original config file of M8n XXL version to work with PixHawk type controllers?

Could toilet bowling be caused by gps?

You don’t need to tune your GPS configuration, it is automatically made by flight controller at startup.

Do you observe toilet bowling only in Loiter mode? Usually toilet bowling is caused by a wrong compass orientation. Did you tune your Loiter PID settings.

I’m thinking that may be after upgrading a FW to v3 it changed or reset something.
Compas is looking forward, same as FC. And external 180 roll, so it is 100% correct.

Copter is super stable in stabilize, AltHold, acro, but in Loiter and PosHold it is crazy with normal loiter PIDs of p=1 I=.5 d=0(can not be set)

The only way to limit crazy expansion of the radius was to set I minimum.

I think my unité may be faulty…

If your GPS unit is faulty we will exchange it. Have you looked at your logs to see whether GPS position is hazardous?

Ok, I will take a copter with GPS outside, power it up, and than connect with USB to computer. I will let it sit in one place for few min, and than run with all of that, a few rounds.

Can you please share the standard settings for GPS so that I can try to upload them and see if it makes any difference from my settings

Basic settings are :

Ardupilot :

  • Baudrate : 115200
  • Refresh rate : 5Hz
  • Messages : NAV-SOL, NAV-STATUS, NAV-DOP, NAV-VELNED and NAV-POSLLH
  • Dynamic model : Airborne 4G

PX4 :

  • Baudrate : 38400
  • Refresh rate :
  • Messages : NAV-PVT
  • Dynamic model : Airborne 2G