Drotek M8N not recognised

Hi everyone,

i have a Drotek board with an Ublox M8N receiver. My goal is to connect it with a raspberry (running Rasbian OS) and record the raw measurements. The way I will record them is NOT my problem now (I will do it with socat or a script). My problem is that the receiver is not recognized ( I check with lsusb from the terminal). If I connect the Ublox Evaluation Kit M8, everything works fine. I have tried also to connect it to Windows 10 and run Ucenter. I have installed the drivers from this path “https://www.u-blox.com/sites/default/files/products/tools/UBX-GNSS-CDC-ACM-windows_Driver_(UBX-drv-v1.2.0.8).exe.zip” in the pc running windows, but it is not recognized again. In the device manager it is shown as a USB device with an error (exclamation-mark). The receivers seems to work fine. If I connect it with a USB, the blue light is on automatically and the green light blinks some seconds later. Do you have any idea what is going on?


Can you try the UART port to check whether the GPS is working ?

Maybe the USB port has been damaged, in that case please open a ticket there and we will inspect/repair/replace it.

I thhink the UART is working, but I cannot record the messages. So far I have done the following steps to record the messages from UART
from the terminal I opened the configuration file with the command: “sudo nano /boot/config.txt"
then I added the following lines and saved it
"dtoverlay=pi3-disable-bt” to disable bluetooth
"enable_uart=1" to enable the UART
in the end I disabled the Serial Console with the command: “sudo nano /boot/cmdline.txt”, I removed the phrase “console=serial0,115200”. In order to record the messages, I write the command: "socat TCP-LISTEN:6000,fork /dev/ttyACM0,raw,echo=0,crnl>gps.ubx"
I tried the same without disabling the serial console, but no message recorded.

Am I doing something wrong in the procedure?


I am not sure how to disable console on Pi’s UART. If you can, give it a try with a real USB-Serial converter otherwise please send the module back so we can check everything, not being able to connect it via USB already looks like a problem.

Hi everyone,

I have connected the receiver with the UART and it communicates with Windows and Linux computers. When I connect it with u-center, I go to the configuration mode and in the <> menu I choose Target:1- UART1, Protocol In:0+1 -UBX+NMEA, Protocol Out:0+1 -UBX+NMEA, Baudrate:9600. Then on the <> menu I deactivate all NMEA messages because I dont need them (but if there are present there is no problem) and I try to activate the raw data with the option 02-15 RXM-RAWX on the UART1, but there is nothing shown in the console. Do you have any idea what is going wrong?



M8N is not suitable for rwa data. It is a software limitation enforced by u-blox. The raw data capable module is the M8T, which is more expensive.

It appears that previous versions of the M8N firmware did allow the output of raw data.