Community forums

Firmware Version in the PixHawk Pro

I have tried to update/confirm the version of the firmware loaded into the PixHawk Pro that I have. When I connect with QGroundControl running on a Mac Pro and select the firmware tab it comes up that it cannot update the firmware.

The PixHawk works OK however I am not sure if I have the most current firmware if it won’t update or see the update server to check.

It says that it is Ver1.6dev - is that the most current version?

Your Pixhawk Pro is flashed with master branch. You cannot flash it with QGroundControl yet as its bootloader returns a different board version. All these functionalities will be added at the official release.

If you wish to change the firmware you must compile it and select Custom firmware file before the upload.

Hi Kevin,

I have a Dropix 3 Pro, I tried to update it with QGC, I tried several times each time with error but the last time it worked, Dropix pro seems to work fine but i didn’t install it on my drone yet, how i can verify that the autopilot is OK after update ?

You can see the software version in QGC, Parameter window.

You can check additional versions with the “ver all” command in Mavlink console.