GPS 3d lock, no RTK

Hello,

I´m working with px4 and rover (installed on the rpas)/XXL ground station RTK.

On Qground control I have GPS signal with rover but no RTK signal. I have gps 3d lock.

What can I do?

Thank you.

Mikel

Hello,

Can you send a screenshot of the log you get on QGC’s console (“Q” icon, then “Console”)?

It might be a driver issue, QGC only recognizes standard drivers from u-blox, not VCP drivers.

Helo kevin,

Is this screenshot?

Yes thank you, your base is not recognized by QGC, could you try updating your drivers following these instructions :

1 Like

This screenshot is “the rover” not the base.

This new screenshot is the base log.

Ah sorry, it looks ok. Don’t change drivers.

Have you waited until Survey-In process is complete? QGC will not inject RTCM data until it has not reached a 1 meter precision position.

1 Like

My problem is that I don´t know if this gps message is ok or not, I mean, GPS 3D lock in qground control.

By other hand, I don´t know if the telemetry link is working or not.

I have the GPS RTK connected to GPS port in my pixhawk, the telemetry is connected to TELEM1 port. Is this ok?

Is it necessary the bridge on the rover board? I have made it.

What GPS message are you referring to ?

Could you post a diagram of your connections?

I have GPS 3D Lock on qground control, no 3D RTK GPS Lock.

This is my connections diagram.

Got it, thanks. What you should do is :

  • connect your base to QGroundControl via USB
  • unplug the radio from your base and connect it to QGroundControl via USB directly
  • solder the bridge on rover
  • leave Pixhawk connections as is

That way you can use the same pair of radios to have MAVlink telemetry data coming from the drone and also differential data going to the drone within the same link.

Thank you Kevin for your answer.

I would like to know if is possible start this system without depending on the QgroundControl (and the computer).

When I go to work with the rpas my ideal system is the ground antenna (XXL RTK GPS system) and the rpas with tiny RTK. Is this possible?

Thank you

Hi Kevin,

This system doesn´t work… What can I do?

connect your base to QGroundControl via USB
unplug the radio from your base and connect it to QGroundControl via USB directly
solder the bridge on rover
leave Pixhawk connections as is

Hello Again Kevin,

It works!!!

Thank you!

1 Like

Great!

Just wanted to add that the dedicated radio setup is not possible with PX4 firmware without modifying the code, whereas it is possible with Ardupilot. You should probably prefer the encapsulated setup as it is easier to have in general.