GPS-i2C drotek et la version "I2C_GPS_NAV_v2.2Beta"

Je suis en train de finir le guide pour l’utilisation du GPS avec la nouvelle mouture du soft I2C.
Ceci facilite grandement la mise en fonction du GPS drotek, et améliore les performances génerales du GPS en vol.
fernitronix.fr/multi-copters/mise-a-jour-i2c-gps-nav-v2-2-betar1

For people who speak english :
there is a new version for I2C-GPS-NAV, this new version make installation easier.
I’ll explain here how to install and configure your GPS as soon as possible…

English “fast procedure:”

-Unsold the jumper beside the GPS board.
-Put standard FTDI
-compile and upload “EEPROM_CLEAR” sketch from arduino software (file/exemples/eeprom/eeprom_clear)
-resold the jumper
-Now you must use a crossed FTDI (RX and TX are swaped)

-start the GPS and start mini-gps-tool.exe. chose the right com port for your GPS
-press ALT+S and go to setup layer
-Put theses settings and don’t miss to clic on confirm/set button:

http://wareck.dyndns.org/component/joomgallery/image?view=image&format=raw&type=orig&id=242

go back to status layer, and click “CLOSE”

-unsold the jumper in the backside
-use the “standard” FTDI
-open 2C_GPS_NAV_v2_2.ino
modify theses lines:

#define GPS_SERIAL_SPEED 38400 to : #define GPS_SERIAL_SPEED 115200
#define NMEA
//#define INIT_MTK_GPS (this is very important otherwise you have to restart all from the begining !)
#define SONAR in **// #define SONAR ** (if you don’t have sonar of course…)

-build and upload software…
-resold jumper…

That’s all…very easy with this version…

Olivier

Bonjour Olivier,

Merci pour ce tuto.
Je me suis lancé dans la mise à jour mais dans mon cas, les choses ne se passent pas bien.
J’ai suivi la procédure à la lettre mais hélas rien n’y fait.

Au boot, point de 3 flash de la LED verte. Au bout d’un certain temps, la LED bleue s’éteint, preuve que le positionnement 3D est acquis.
Mais la led verte clignote à 1 seconde d’intervalle. Si l’on en croit la documentation de la R33 (code.google.com/p/i2c-gps-nav/downloads/detail?name=r33-documentation.pdf - page 7), cela veut dire qu’aucune donné NMEA n’es transmise par le GPS.

J’ai refait 2 fois le travail mais rien n’y fait.

J’ai creusé un peu du côté du GPS.
J’ai trouvé un comportement étrange dans Mini GPS. Il acquiert le 3DFix mais aucun satellite n’apparait dans la fenêtre.
J’ai testé avec un autre GPS série et là, chacun des satellite apparait bien dans la fenêtre.

Bref, je suis coincé.

Aurais-tu une idée de l’origine du problème?
J’ai vu qu’il y avait un firmware dédié aux capteur MTK mis à dispo par eosbandi (code.google.com/p/i2c-gps-nav/downloads/detail?name=AXN1.51_2776_3329_384.1151100.5_v19.bin&can=2&q=).
Le souci c’est qu’il est apparemment destiné aux capteurs dont le chipset est PA6B et non PA6C comme le mien (drotek.fr/shop/en/88-i2c-pa6c-gps-llc.html)..)
Je n’ose pas tenter la mise à jour de peur de le bricker…

Merci.
-arnaud



Bonjour,

Bon deja, ton GPS est bien fonctionnel, sur la copie d’ecran que tu as mis, on vois apparaitre le firmware, et il decode des coordonées.
Lorsque l’on utilise le soft I2c-GPS-NAv, le signal est remis en forme pour le multiwii,ceci à pour effet de supprimer les lignes de codes des spots satelitte.
Il est donc normal que les point bleue n’apparaissent plus dans le soft miniGPS… :wink:

Tu n’a pas besoin de mettre à jour le firmware du GPS, celui livré d’origine fonctionne à merveille avec les applis du multiwii…

Je pencherais plutot sur le decode NMEA.
La led bleue s’etein quand le GPS à fait son point dans l’espace et qu’il à au moins une position en 2D.
La led verte qui clignote lentement explique que le flux de donnée n’est pas viable pour le multiwii…

ce que je te propose de faire sans avoir à trop bricoller dans un premier temps:
-tu dessoude le pont derriere la carte
-tu injecte le soft “Eeprom clear” de l’arduio dans la puce.
-Tu ressoude le pont et tu demarre la carte en utilisant un FTDI croisé, tu regarde ce que te dis mini GPS.
Verifie à deux fois que tu as bien paramétré le flux de données comme ceci:
http://wareck.dyndns.org/component/joomgallery/image?view=image&format=raw&type=orig&id=242

dans la case du bas, tu dois avoir un debit d’information avec des chiffre et des lettres…
Un fois fait, tu quitte le soft mini gps.
-tu dessoude le pont gps
-tu reinjecte le soft i2cgpstools avec les reglages que je préconise…
ATTTENTION, je viens de modifier un code, car la mise à jour de la derniere version pose un petit problême avec mon ancien code, si tu ne te sert pas du gps pendant quelques jour, le soft deconnais…J’ai corrigé sur mon post précedent
-Tu ressoude le pont.
-Maintenant petite subtilité, une fois demarrer, tu vas à l’exterieur, loins des batiments, au moins au premeir demarrage pour que le GPS detecte les satelittes sans les reververations des ondes sur les murs…
Le premier demarrage peut etre long (5 minutes), mais les suivants seront rapides…

Voila tu fait deja cela, et tu n’hesite pas à nous recontacter si tu a toujours des difficultés…
Olivier

Bonjour,

Merci pour ta réponse détaillée.
Alors, oui, j’ai exactement les mêmes paramètres nmea que sur ta capture d’écran.
J’avais scrupuleusement fait attention à ça. :wink:

En revanche, je ne comprends pas un truc: la capture de Mini GPS - sans les points bleus - a été faite alors que j’étais connecté en direct sur le GPS via ftdi croisé.
L’EEPROM de l’atmega était vidée. Du coup, comme j’étais connecté en direct et non au travers de l’atmega, je devrais bien voir les points bleus apparaitre, non?

Parce que j’ai testé avec un autre GPS série(Drotek d’ailleurs), connecté de la même manière, j’avais bien les points bleus qui apparaissaient.

Sinon, quel(s) changement(s) as tu fait dans ton code?
Je n’ai pas trouvé.

Merci!
-arnaud

Oui c’est normal.
Quand l’eprom est vidée par le soft “eeprom clear”, le gps ne l’utilise pas.
La donnée NMEA part donc directement vers les prises du FTDI et le soft gps mini exploite en live la donnée…

Quand la puce atmega est programmée, les données du gps, passent par la mémoire, puis sont traitées avant d’etre envoyées vers le port FTDI.
Ce temps de calcul, plus la remise en forme du signal fait que le soft GPSmini est perdu et n’offre que les reglages et les debits de données.
De plus en activant les options GSA,RDS,CGA, on désactive les autres options, une d’entre elle (je ne l’ai plus en tête) permet “l’habillage” des satelittes et les infos meteos.
(ce qui explique pourquoi ils ne s’affichent plus)

Dans le concept d’utilisation du gps pour les helico, tout ce qui est fioriture est enlevé, il faut vraiment s’axer que sur le debit de donnée.

Pour les modifications du soft, c’est le sujet juste au dessus de celui que tu as posté ou alors : wareck.dyndns.org/multi-copters/mise-a-jour-i2c-gps-nav-v2-2-betar1

Si tu galère encore, branche minipgs, et prend moi une copie d’ecran des données qui defilent dans la page “setup”

Olivier

Merci, je vais regarder ça ce soir.

Juste pour être bien sûr, est-ce que cette ligne doit être commentée ou non?
//#define INIT_MTK_GPS Super important !!! sinon vous serez obligé de recommencer du début !!!

On exploite cette feature MTK ou pas?

Non il ne faut pas la commenter, sinon le gps demarre avec sa config par defaut et ne tiens pas en compte tes reglages…

il faut bien ecrire ça : //#define INIT_MTK_GPS

L’option ne sert à rien et au contraire pose probleme avec ton gps…

euh, si l’option pose problème, il ne faut pas l’activer, donc commenter la ligne, non? :wink:

Oui :wink: enfin rajouter les //

BINGO!

C’était donc cette ligne qui foutait la *%#£$^
Merci Wareck!

Ne reste plus qu’à tester ça en l’air.
Pour le réglage des PIDs GPS, il existe un tuto quelque part?
J’ai cherché mais sans succès.


Pour les pid du GPS? tu laisse les valeurs de bases ça marche très bien.
En fait le gps agis sur le magnetomètre. il faut deja avoir une machine nickel en vol standard avant de tanter de regler le GPS.
Personnellement je ne touche pas au reglages dans le GUI, mais ceux dans le code source.
Il y a peu de correction à faire…