GPS SAM M8Q communication

Hi Drotek,

I bought from you a GPS UBLOX SAM M8Q a few months ago and I am now trying to hook it to my Arduino Micro 5V board.

I use the Arduino Serial1 interface (TX RX hooked to the RX TX on the GPS board). I have set the serial rate to 9600 bauds, the serial is ready but does not receive any bytes at all.

The GPS module permanent blue led turns on and he green led blinks every seconds. But no bytes seems to output.

Can you help me?


What is the voltage level on your Arduino? SAM M8Q uses 3.3V.

The voltage is 5V. Now I understand that the SAM M8Q has a voltage regulator (3V 5V) but the RX TX outputs are 3.3V signals. So I suppose I need some kind of level shifting component between the two devices.

I also have a 3.3 Pro Micro Arduino board from Sparkfun so will try the SAM M8Q with it and will keep you informed.


Hi Kevin,

I tried the 3.3V Pro Micro board (=Arduino micro) and I have the same problem : no incoming bytes, even with the green FIX led blinking.

I then tried the Arduino Software serial (UART emulator on two IO pins) but to no avail.

I looked at the SAM M8Q TX signal with my Pico Oscilloscope and I noted that the TX pin is at a steady 3V (with a small 1 Hz fluctuation beat) while the green led was blinking.
Is this behavior normal? It seems that nothing comes out of the SAM M8Q TX pin. What do you think and what should I do? Should I write a reset byte to the GPS?

Thank you very much for your reply.


Hi Kevin,

OK there is a problem with my SAM M8Q GPS module

I hooked an old EM-406 to my 3.3V Pro Micro Arduino board and everything is OK. The EM-406 is powered by a 4.8V battery. The negative pole of the battery is hooked to the board GND.
The baud rate is set to 4800 for the EM-406 and I receive the data.

Now if I replace the EM-406 with the SAM M8Q (and switch the baud rate to 9600) nothing happens : the SAM M8Q is silent.

So something is wrong with the SAM M8Q.

Should I sent you back the GPS module?

Thank you for your reply,

OK someone from the Arduino forum solved my problem.

Drotek you have switched the TX and RX pins labels.

Now the board works well at both 5V or 3.3V.