Community forums

How to setup TinyRTK on PX4 Firmware with QGroundControl properly?

Hi,
i have the old TinyRTK with solder bridge. I want to use it directly connected to the Pixhawk with PX4 Firmware stack.
The UART cable is connected to the Rover Port of the TinyRTK. The Telemetry module is connected to the Pixhawk. My Solder-Bridge is soldered on Rover-TinyRTK. Is that correct?

A second TinyRTK is not soldered and connected to PC via USB. QGroundcontrol is running.

Qgroundcontrol shows that it is streaming RTCM. the mavlink shell on the drone says with command “gps status” that rtcm is injecting.
BUT
my drone says just 3D Lock. no 3D RTK Lock (float/fix).

I thought QGroundcontrol and PX4 are setting everything for me? I have tried do configure by hand. but it didnt change anything.

i dont know what to do.

best regards

Hi Tobi,

The inbuilt configuraiton on Pixhawk3Pro will automatically do the job.

However, first make sure there is a working wireless data stream between the PC and the Pixhawk3Pro so that RTCM data can be sent out to the Pixhawk from the base (Same ID, PIN and baudrate, etc…)

Thereafter, make sure to tick the “RTK GPS” option under “General” and then scroll down. (see picture below)
image

Paul

Thank you. The problem was a loose JST GH cable. I also tried an emlid module and saw how the LED went on and off when I touched the cable. I didn’t see that with the TinyRTK. Despite voltage it still didn’t work. I guess the RX wasn’t properly contacted either. Now it goes with another cable.

1 Like