LoRa HM-TRLR-S connecting troubles

Hi friends
Need to use this device with Dropix V2 and on three different systems: A smartphone with android and 3DR tower GCS, a PC x32 with XP and Mission Planner and a PC with Windows 10 with Mission planner too. At this mommnt the three devices are running fine with a 3DR data link
Have modified the LORA cable to use 5V/Gnd/TX/RX leaving the other two unconnected.
Once pluged the blued led Lights steady on both ends, the port is recognized but it is unable to entablish a connection. A tiny green led blinks once per second on the PC/Smartphone part while a red tiny led blinks on the DRONE part of the data link.
Both PCs has netframework 4.0 or higher.
Have dowloaded from hoperf.com/data_link/HM-TRLR-S.html the config setup and drive on the resouces label and instaled the config program to have access to the basic LORA params (power, band …) but I was not able to connect to it too, (READ button end with a failed to read advise). No idea if the driver on the web is the right one for those PC systems.
The instalation of the program and driver on windows 10 seems to be a challenge as most of the letters appear in chinese while in XP some appear as blanck squares. On the Smartphone there is no apparently need to install any other thing the same way I didn´t need to do for the 3DR Data Links.
For sure it is a stupid fail Im doing but actually Im copletely lost. Any idea?
Thanks in advance


You have to put the jumper to configure the LORA module.

No luck, tried with the jumper in all combinations (placing it before powering and once powered, being connected by the USB only and with the USB plus the 5V/gnd/tx/rx wire to the powered DROPIX). I all case the same result, I choose the port, set the bandrate (all from 9600 to 115200) and click Open but all intends to read the actual configuration ends on a red READ FAIL label at the bottom of the config program.
It is supposed it should directly work as it comes from factory?
are both data links matched?
The is no need to add any other thing beyond the 5Vgnd/tx/rx wire to the dropix for the air unit and a usb to the PC on the ground unit, right?

You need to place the jumpe. Then you plug the USB cable to the LORA module.
You start the config soft from HopeRF.
And you click to connect to see all parameters.
Can you confirm that doesn’t work please?

I do it exactly the way you described.
I select the connect button and then the READ and WRITE buttons becomes usable but nothing else more. I can click the read button and shows a failed to read or click write and shows failed to write.

In case you start de HopeRF program without having any LORA connected to the USB, the results are exactly the same with the difference that you will not be able to choose the right port becasue without LORA to USB there is not any device detected and therefore not a port assigned to it but the reults are the same . All fields on the config screen are already filed with numbers except the port field. I can click to connect (which obviously doesnt connect to anything) but that enables the READ and WRITE button too. That means the is no connection either with the LORA plugged or not. Beyond the config troubles, if they are ready to use as they come from Factory it should directly work when trying to connect from the Mission Planer or Tower Droid but both cases are imposible to do. May be they are set to different channels and or freq, who knows.

The HopeRF program you use is the same I linked on the first post?

If not, could you point me to the config software link and drivers link your are using?

Thanks Jerome

The soft can be downloaded here hoperf.com/upload/rf/HM-TRLR-PCConfig.rar.
You can create a ticket on drotek.freshdesk.com and send us back the modules please.

The software I downloaded is the same as the one you posted above. Opened a ticket as requested. Have double check the LORA to DROPIX connection, please confirm me like other data link, the LORA TX and RX needs to be crossed in its way to dropix unit (TX to RX and RX to TX) the same way I have on the currently working 3DR link, right?

Yes you are right.
You can test too with an Hyperterminal and FTDI on each module.