M8T for 3DR Solo

Hello I have just installed the plug and play M8T GPS module in my solo and is there any more steps to it more then installing the hardware? Tried starting up the drone and I recive 0 GPS signal?? What could be wrong?

It should work plug and play. Is the LED on when you plug the GPS? Have you tried connecting the USB to your computer to check if you get signal?

Hi everyone,

any news about the p&p GNSS for Solo? Is it work good Andreas? I’m interesting to order one, but I ordered other Drotek products in the past and I have already encountered other problems, mainly with GNSS and the pixhawk controller … like in the Solo. Is it really p & p? Must update the firmware of the uBlox chip or is it already done (> 3.01 I think). Do I need to change some parameters in Solo?


Two days ago I’ve received and installed 3DR SOLO GPS (NEO-M8T) on my SOLO Drone.

Like documented, it replaces the stock SOLO GPS nicely and everything fits exactly in place.

One advantage of this M8T is the extra USB connection that drotek has granted by adding a mini-usb port on the board. It was cleverly placed so you can connect to it after closing SOLO (without the GPS cap):

I would only recommend drotek to place the usb connection a 1 or 2 mm to the right so it fits exactly in the center of the hole, so we don’t have to slightly cut the usb plug on the left to be able to connect to it (like I did, marked on picture above).

Using this usb extra port I’ve connected my laptop to it (with or without SOLO power on) and use the ublox u-center software available for windows / android. It rapidly fixed GPS position with 12 GPS on my backyard, that the stock GPS usually achieved with 8 GPS.

Drotek recommends upgrading SOLO to Autopilot v1.53 to benefit from rtk functionalities.

I’ve done the 1.53 upgrade before using the official repo following a 3DRpilots guide, like explained on my 3drpilots post. And have been flying SOLO with success.

So my questions are:
1. Drotek github “ArduCopter-v2.px4” is the same has the 3DR github “ArduCopter-v2.px4”?
Because I can see on the drotek repo a commit to “Correct MAVlink definitions” and “This pull request aims at adding data injection functionalities to 3DR Solo in order to use with u-blox M8P (RTK) chip.” Since M8T also has RTK capabilities must I install the drotek 1.53 version to get support for the GPS_INJECT_DATA and GPS_RTCM_DATA MAVlink messages?
I was planning to try Mission Planner with a Base DGPS (RTCM3 connection) to inject GPS corrections into SOLO/M8T. How can I achieve that?

Second question:
2. Should I use u-center to install any firmware into M8T or change the GNSS configurations to get the most of this GPS upgrade on SOLO?
For instance drotek recommends a firmware upgrade to M8P!
My M8T GNSS configurations (on u-center) come with Galileu, BeDou not enabled. Should I enable them?


  1. “ArduCopter-v2.px4” from Drotek’s GitHub account is not the same as 3DR’s one. The difference is exactly the one you pointed, that is to say a modification of the set of MAVlink messages in order to enable data injection within the GPS driver. Actually M8T does not have any real-time RTK capability, it only lets you log raw messages in order to do post-processed RTK (also known as PPK). So it is not really useful to use the patch with M8T. It is however with M8P.

  2. You do not need to use U-Center to change your Solo’s configuration as it will be overwritten at startup. It is however a good idea to keep your modules updated to latest versions in order to benefit from upgrades.

What do you have to do to make the M8T log data? I flew a mission and while it worked as expected, I hooked it up to the PC via USB and U-center said no logs were present.

Logs need a special procedure documented here : https://www.u-blox.com/sites/default/files/products/documents/u-blox8-M8_ReceiverDescrProtSpec_(UBX-13003221)_Public.pdf p.71

You can only log a very limited amount of data with that procedure. It may be easier to log on the autopilot side.

Hi Kevin:

Do you have any direction on logging the data on the autopilot side. I’m using the M8T on my solo and dont (or at least cant find) the GPS_RAW_DATA. Any direction would be appreciated.


I thinkyou might find the solution on:

With GPS_RXM_RAW, but you will onlybe able to usegps data and not other GNSS data.

The " GPS_RAW_DATA" is available in newer arducopter version than the stock solo arducopter (1.5.1). I upgraded to the 1.5.4 ArduCopter Solo, but I still can’t find this function unfortunatly! I saw thi parameter in the parameter list in MP on a classical pixhawk with an arducopter 3.4.X i think. Does drotek have a solution?

The link to 1.5.4 arducopter solo release: