Community forums

MPU9250 don't responds to the movements

image
Bonjour.
Hello.

J’ai un problème décrit ci-dessous et j’éspère que quelqu’un trouvera une solution.
I got a problem described here and i hope that someone will find a solution.

J’ai commandé et reçu votre mpu9250.
I ordered and received your mpu9250.

J’ai téléversé votre code d’exemple (https://github.com/Frogofmagic/MPU9250/blob/master/MPU9250Main/MPU9250Main.ino) dans une carte arduino UNO.
I uploaded you example code (https://github.com/Frogofmagic/MPU9250/blob/master/MPU9250Main/MPU9250Main.ino) in a arduino UNO board.

J’ai connecté le mpu9250 de différentes manières à la carte arduino comme illustré sur les images 1 et 2.
I connected the mpu9250 in differents ways to the arduino UNO board like illustrated on the images 1 and 2.

J’ai aussi essayé d’autres connections en inversant A5 et A4, SDA et SCL et en connectant le 5V du mpu9250 au 3.3V de la carte arduino UNO.
I also tried other connections reversing A5 and A4, SDA and SCL and connecting the 5V pin of the mpu6050 to the 3.3V pin of the arduino UNO board.

Le problème est que les valeurs de l’accéléromètre, du gyroscope et du magnétomètre sont toujours les mêmes au démarrage du moniteur série arduino, et ne changent pas même lorsque je bouge le mpu9250, comme illustré sur l’image 3.
The problem is that the accelerometer, gyroscope and magnetometer values are always the same when the arduino serial monitor starts and they don’t change when i move the mpu9250, like illustrated on the image 3.

Pouvez-vous svp trouver une solution à mon problème ?
Can you please find a solution to my problem ?

Cordialement.
Cordially.

Antoine.