NEOM8T RTCM3 Issues errors base station errors

Hello, everyone!

I am currently doing a university project and my goal is to use DGPS to navigate a rover.

I use the RTKLIB software at the moment - RTKNavi (but in future I will use RTKRCV as I will finalise it on a Raspberry Pi)

My current set-up is 2x Neo M8T rtk ready boards (from CSG Shop), SiK 433 MHz kit and a laptop.
I am currently having the following problem - no base station observation data for rtk and point pos error.

I also cannot enable the RTCM3 messages in u-center. Any suggestions?

Thank you in advance!

Hi,

You don’t need to enable RTCM3 messages in U-Center as your M8Ts are only used for raw data generation. RTKlib will then do the job. Have a look at your log files generated by RTKlib and look at if you have differential data being transmitted correctly.

Hey, Kevin!

Thanks for your response!

I am relatively new to all this and I really don’t know what to look for when I look at the log files.

I am now using the following set up:
-Raspberry Pi 3

  • 2x Neo M8T
  • Radio link - 433 MHz telemetry kit (SiK radio) and it is matched via mission planner.

Base station: I power the radio with an adapter (micro usb end) and the 6-wire Pixhawk cable goes to the telemetry slots of the board and that’s how I power the board. The inputs of the telemetry on the board are - Gnd, SDA, SCL, Tx, Rx, +5V.

Rover: Raspberry Pi is power by power bank. Other radio connected to it, second Neo M8T and a monitor plus keyboard and mouse.

I have rtklib installed on it and I use rtkrcv.

Could you, please, suggest what configuration of files should I use? I am banging my head against the wall for more than a week…

Thanks in advance!

UPDATE: It give me the error from the photo…

I also see that the “Time LED” on one of the boards is not blinking. It’s on the one connected to the Pi. It only indicates that the board is powered (white led)

I cannot help you with hardware architecture from CSGshop boards because I don’t have their schematic.

However it looks like you have a permission problem :

  • are you logged as “root”
  • does your user own the repository you are working on (look at “chown” function)
  • otherwise try prepending “sudo” to your commands

I upgraded the OS to latest version, enabled the serial ports, literally everything that I have read.

I think that my config files are not correct but I have no idea how to adjust them for my connection.

I cannot even get a single solution. It still gives me the server start error and path=tty thing… I am pretty sure it is a problem coming from the config files. The Pi 3 reads everything I plug in.

Could you, please suggest what I should do in the configs? I am using Neo M8T and SiK telemetry.

What is the output of ls /dev/tty* on your Raspberry?

This is what I get after I type laptop /dev/tty*

When I remove the GPS module ACM0 disappeared. So, it would be it I suppose. But it still gives me the error…

Have you tried with sudo?

Hey, I am working on a very similar set up, and I was wondering if you ended up solving the problem. I did not begin yet in setting it up on the Raspberry Pi, but figured it would be of help to me (and others) if you told us whether or not you solved the problem. Thanks!

If you need reference configuration files you can have a look at our SmartNav project on Github.

1 Like