New F9P not getting time of position fix

Hi,

I bought two DroTek F9Ps. The first one achieves an estimate on UTC time pretty quickly and the yellow light blinks and achieves a GPS fix, but the second one never even estimates the time or achieves a fix. I don’t see any SNR for the satellites either. I used the same antenna for both of the units. All of the GNNS constellations are enabled for both units.

Any ideas why the second unit would be behaving like this or what I can do to fix it?

Thanks,

Rob

Can you provide NMEA /RTCM log file on it ?
How do you configure your F9P ?

I just used the defaults to start with. I think it should be able to get a normal 3D fix without any tweaking. I verified that all the constellations were enabled.

Its like its not seeing the satellites:

Perhaps you need to restore the default configuration.

Drotek proposed 2 default configuration files (1 for Basestation and 1 for Rover), select the Rover configuration file and follow the instructions here (very simple):

https://drotek.gitbook.io/rtk-f9p-positioning-solutions/tutorials-1/zed-f9p-rtk-configuration

Bad news is all Galileo satellite is down ( 11-Jul-2019) : (read more)
Anyway, the F9P has a new firmware yesterday (12-Jul-2019), if your status has not been improved, you may consider updating to the latest firmware.
Download it here:
https://www.u-blox.com/en/product/zed-f9p-module#tab-documentation-resources
And go to this post to learn more about update firmware for F9P Drotek :
https://drotek.gitbook.io/rtk-f9p-positioning-solutions/tutorials/updating-zed-f9p-firmware

Thanks for the heads up on the firmware. I updated the firmware, but there is still no signal.

The Real Time Clock Status never changes to calibrated:

This is how it looks with the working F9P:

Did you load to F9P -Rover configure file yet ?

I loaded the base and rover with no change. My gut feel is that there is a hardware problem.

Do you know of any other hardware diagnostics that can be run?

Your F9P still working -> Good.
But it seems like satellite signal is not good enough and i’m pretty sure this is Antenna problem or connection Antenna problem.
Replace antenna B for F9P_A , antenna A for F9P_B and see the result on both F9P_A and F9P_B.

The antenna on the problematic f9p worked on the good f9p.

If you think there is a hardware issue, please open a ticket here please https://drotek.com/contact-drotek/after-sale-service/

1 Like

So, both antenna worked and if both two F9P is good, then problem is connection between F9P and Antenna.
It using Active antenna ( Patch antenna ), when you check, the power supply put on antenna must be 3v to 5 volt and the current go through antenna when it work will higher 15mA.

I did that too on Saturday. Thanks.

@jerome, do you know of any hardware diagnostics tests I can perform to see if it is a hardware issue? I wonder if the RF from the antenna connection is getting propagated through to the F9P. Would there be any other reason that it would never achieve a time lock when the other F9P achieved it within 30 seconds with the same antenna and collection location.

I think the problem is either the software or the hardware of the F9P. It’s difficult to give a solution. Try the same configuration between both of your modules. If there is a difference then open a ticket and send us back the faulty module.
Thanks

I already opened a ticket (1473). Shouldn’t the GPS be able to get a normal fix with the default settings?

I really need working hardware by the end of the week.

One of our engineers will reply quickly.