New RTK Kit - Not working!

Hi
lately we have order RTK KIT which contain the following devices

  • 1 x ublox RTK XXL module > The Problem device is not connecting to PC using USB and the PC is sad that" USB is not recognized "

  • 1 x ublox RTK XL module > The Problem device is not connected to the PC ( no message in PC ! )

  • both device is getting PWR ( Blue LED is llight is and afterwords the GREEN light is blinking )

  • we have tried this in diff PC’s and get the same problem

BTW -we already have an Extra Rover XL RTK GPS which is connected well and working well

what should i do ?

Hello,
Have you tried with another USB cable? Do you have a XL RTK GPS from Drotek which works?

Yes - i have tried another USB cable - still didn’t work
Yes - i have a XL RTK GPS from Drotek which works in the same configuration.

It’s very strange since there are no additional components between the USB connector and the M8P.
You can contact our service after-sale and send us back the board.
Thanks

Yes we are very disappointed .
i am wondering if there is QC procedure before shipments… ?
only 1/3 units is working!
anyhow we will shipped is directly to you
it possible to send us a new one ASAP since we have a project and it might hit our schedules
it can be great if u can contact us directly

Shay

All boards are fully tested before shipping. We have less than 0.1% of faulty GPS modules.
It’s difficult to tell you what is wrong with your board.