No RC input (Taranis9XD+, X8R SBUS)

Hello every body,

I am facing a problem with my piwhawk 3 pro.

I have downloaded the last version of QGC (3.2.4). I would like to set up my drone (hexa) with the last stable version of PX4 (1.6.5dev). The firmware was downloaded successfully on the board. So when I want to calibrate the radio I cant. It does not find any channel…

When I plug the board to QGC I have an error message “Failed to communicate with IO, abort.”

I looked at the Mavlink console with “px4io status” and nothing because I have to start it. So, I enter “px4io start” and the message is “Failed to communicate with IO, abort.” or “IO protocol/firmware mismatch, abord.”

I searched for several hours but I can’t succed to find the solution. I think this error very weird with the last stable release…

I hope you could help me.

Hello,

Could you try to force the update with the console? The command would be “px4io forceupdate”. What is the output in that case?

Thanks.

Hi,

Thank you for you answer Kevin.

I tried to enter the command you give me and I have this: “WARN [px4io] usage: px4io forceupdate MAGIC filename”

After that, use “px4io statut” and I have this:

nsh> px4io status
WARN [px4io] loaded
protocol 2147483648 hardware 2147483648 bootloader 2147483648 buffer 2147483648B crc 0x8000000080000000
2147483648 controls 2147483648 actuators 2147483648 R/C inputs 2147483648 analog inputs 2147483648 relays
14662 bytes free
status 0x0000 SAFETY_SAFE RC_FAIL FMU_FAIL MIXER_FAIL ARM_NO_SYNC INIT_FAIL
alarms 0x0000
actuators
servos
reversed outputs: [] trims: r: 0.0000 p: 0.0000 y: 0.0000
0 raw R/C inputs
R/C flags: 0x0000
mapped R/C inputs 0x0000
ADC inputs
features 0x0000
arming 0x0000 FMU_DISARMED IO_ARM_DENIED
rates 0x80000000 default 2147483648 alt 2147483648 sbus 2147483648
debuglevel 2147483648
controls 0:
controls 1:
controls 2:
controls 3:
failsafe
disarmed values
IMU heater off
nsh>

Does it could be a bootloader issue ?

It looks like the IO processor could not be updated through its bootloader. Somehow the command forced it, did you try again with the RC input?

I tried to use the Radio an nothing.

When I want to calibrate the radio, it’s like if I didn’t connect anything. I can read “Detected 0 radio channeles…”

I tried the command “px4io test” and It faild with error no=2 :

ERROR [px4io] failed to open device
ERROR [px4io] Task exited with errno=2

We have seen cases where a bad power supply could cause this behaviour. Could you try using a good USB cable? Could you also try to do the same operation while powered with a battery?

I tried with an other computer and it is the same. I have got a problem and can’t communicate with I/O.

If I try this operation while the battery is plugged, I can’t upload the firmware, the operation stop.

It is difficult to diagnose the problem without more elements, could you please open a ticket there so you can return it? We will analyze the problem, and repair or send you a new one.

Ok, thank you Kevin. I am going to do that.

Hi Kevin,

Sorry to ask you about my problem by this way.

I did what you said by opening a ticket but I have not any answer for a month…

Maybe you can help me ?

Regards,

CBB.