Only getting "3D dgps" with RTK XK rover and XXL base


I use a pixhawk with arducopter and I am trying to make the RTK XL rover work with the RTK XXL base.
I’ve tried several times all the setups (automatic and manual) but I never managed to get a RTK float or fix.

The base configuration seems to work and I get a green light. The RTCM messages are sent to the rover whose RTK led starts to blink.
But that is the best I get.
The LED never fixes and the highest GPS status I get is 4 (3D dgps). I don’t thik it is related to the environment since I did my tests in an open field and got around 12 satellites continuously. The base station needs less than 30 seconds to get a position within 1.8 m (do I need to reduce this ?).

Did anyone encountered this problem to ? Did I miss something ?

Thanks in advance for your help,


What firmware are you using ?

I’m using Arducopter 3.4.4 with mission planner v1.3.48

This is the reason, you need a more recent version , with 3.4.4 the Ublox GPS is not initialized correctly.

Thanks for the reply,
I will try with a higher version of arducopter but I’m almost sure I read that 3.4 and higher should have worked.

I’ll keep you updated,



So I’ve tried a higher version of Arducopter and managed to go until RTK float but never RTK fix (thank you by the way for your previous tip).
I had a accuracy of 2m for the base lock and was flying in a completely open area. The base module was approximately 1 m above the ground and the rover was installed on a 20 cm mast on a drone.
What should I do to get a RTK fix ? I got the impression I did everything right… is it just bad luck or are there any configurations that I might have missed ?

Thanks for yout help,