[Pack autopilot DroPix] Impossible de se connecter à la DroPix par Sik Radio avec Mission Planner

Bonjour,

Je souhaite utiliser le pack autopilot DroPix afin de pouvoir contrôler un rover avec Mission Planner.

Je me heurte à un problème de connexion au DroPix par le biais des antennes Sik fournies dans le pack.

Je vais donc détailler dans un premier temps ce que j’ai fais car la source du problème s’y trouve peut-être.
Pour précision, je suis sur windows 7.

Dans un premier temps j’ai installé deux drivers :

Que ce soit le module Sik ou le module DroPix, les deux sont reconnus lorsqu’ils sont branchés à mon PC. Un port COM leur est associé sans problème.

La connexion au DroPix par USB sur Mission Planner fonctionne.
J’ai donc réalisé un premier paramétrage de mon module DroPix par USB.

Dans Initial Setup/ Install Firmware : j’ai installé ArduRover v3.0.1. Cela s’est bien passé.

J’ai ensuite commencé le Setup Wizard mais je me suis arrêté à la calibration du compas (justement parce que je ne peux pas amener mon PC dehors et le cable USB gêne).

Après j’ai donc voulu me connecter à mon module DroPix par les modules Sik Radio.

La configuration est maintenant la suivante :

  • module DroPix alimenté par USB via un adapateur USB/prise de courant,
  • module Sik Radio connecté au PC.

Dans les propriétés du port COM associé au module Sik, j’ai pour les paramètres du port :

  • Bits par seconde 9600
  • Bits de données 8
  • Parité Aucune
  • Bits d’arrêt 1
  • Contrôle de flux Aucun

Dans Optional Hardware/Sik Radio :

  • Load Settings me donne le résultat :
  • J’ai réalisé Copy Required Items to Remote puis Save Settings ensuite. (Si je change un paramètre et que je fais cela, j’ai “Set Command error”, mais si je refais Save Settings après, je ne l’ai pas.)
  • J’ai également réalisé Upload Firmware (local) (mais en réalité, je ne sais pas quel firmware…)

Pour lancer la connection, je sélectionne en haut à droite le port COM adéquat et une vitesse de 57600.
La connection attend alors indéfinement jusqu’au timeout un heartbeat.

Status des LED :

  • Module Sik : vert constant (si j’en débranche un, l’autre se met à clignoter jusqu’à ce que je rebranche l’autre),
  • Safety Switch : Double flash rouge puis pause. Selon mes recherches, c’est un vérificatio système infinie…
  • LED du All-In-One : Double flash jaune, puis pause, etc : erreur refuse d’armer,
  • LED ACT B/E IO du DroPix : bleu clignotant.

Ce que j’ai essayé :

  • Passer le paramètre Bits par seconde du port COM du module Sik à 57600 => rien.
  • RawData au lieu de Mavlink => rien.
  • Désactiver ECC => rien.

Qu’est-ce qui peut donc être mal paramétré ?
Est-ce un problème de version de MP, du DroPix (comment vérifier ?), des modules Sik (comment vérifier ?) ?

J’ai remarqué que sur le module Sik on a le RX branché sur le TX et le TX branché sur le RX de DroPix. Cela se voit également dans le 4.6 du guide https://drotek.com/docs-dropix/ : on a 5V GND TX RX pour la DroPix et 5V GND RX TX pour le module Sik.

Merci d’avance pour votre réponse.

Est tu sur que Rx et Tx du module Sik sont connectés correctements sur la Dropix ?

Quel est le modèle de télémétrie svp?

Je pense pouvoir affirmer que le module Sik est bien connecté.

Son modèle… Et bien c’est celui fourni dans le pack autopilote que vous vendez http://www.studiosport.fr/pack-autopilote-dropix-drotek-a10665.html (vous ne donnez pas de référence).

En effet, j’arrive à réaliser la connexion que je veux faire mais cela nécessite :

  • connecter la DroPix et le module Sik au PC
  • se connecter sur la DroPix par USB avec MissionPlanner
  • faire LoadSettings, Copy Required Items to Remote et Save Settings (on voit que deux connections sont faites ici, pour les deux antennes si je ne m’abuse)
  • déconnecter la DroPix du PC, puis choisir de se connecter sur le port COM du module Sik toujours branché au PC et là ça marche, Mission Planner est connecté via les modules Sik avec ma DroPix.

Inconvénients : - si je veux configurer le Wizard, celui-ci ne détecte pas la DroPix donc finalement rien.

  • si j’éteins le matériel je dois refaire la manipulation, comme si ce qui avait été chargé avait disparu. Y-a-t-il un moyen de charger de façon durable les paramètres sur les modules Sik ?

J’espère que cela vous aide à mieux cerner le problème.

Je vous conseille de configurer vos modules sans passer par la Dropix et avec le logiciel http://vps.oborne.me/3drradioconfig.zip
Essayez de changer un parametre et sauvegarder. Ensuite deconnectez du pc et reconnecter. Vérifiez si le paramere est toujours sauvegardé.

Les paramètres modifiés sont bien sauvegardés après une déconnexion-reconnexion. (En connectant, 1 module à la fois et j’ai aussi essayé avec les 2 connectés.)

Néanmoins, même après avoir configuré les modules avec ce logiciel, je n’arrive pas à me connecter à la DroPix via les modules sur MissionPlanner.

Ok donc les télémétries sauvegardes les données. Pour vérifier si les téléms communiquent parfaitement il suffit de brancher les 2 sur un PC.
Ensuite ouvrir un hyperterminal pour chaque télém. Faire un test en écrivant sur la première fenêtre et voir si l’autre fenêtre affiche la même chose et vice versa.

J’ai effectué le test. Et je reçois bien les informations envoyées par l’une sur l’autre et inversement (voir screenshot).

.

En vérifiant avec les commandes AT, les paramètres sont aussi les mêmes.

Je m’en tiens pour le moment à ma parade qui consiste à connecter la DroPix par USB avec l’autre module alimenté, charger les paramètres, vérifier qu’ils sont bons (ne pas faire de sauvegarde). Puis ensuite je peux me connecter via les modules.

Je ne sais pas qu’est-ce qui fait que ça ne marche plus car j’ai plusieurs fois tout éteint et ça remarchait. Puis je ré-essaye le lendemain, je dois refaire la manip’ (le PC avait été éteint).

Si les pametres des telem ne changent pas et que les hyperterminals dialoguent alors cela signifie qu’ils fonctionnent parfaitement. Je ne vois vraiment pas ce qui peut clocher dans votre montage.