Pixhawk connection problem


I received and installed the Ublox GPS0740A0, Ublox NEO-M8N GPS + HMC5983 compass to the Pixhawk. Compass seems to work perfect in Mission Planner but I got problems with GPS: After several minutes outside, I got GPS signal for more than 10 satellites in U-Center, then I disconnect the USB and connect GPS and Compass to the Pixhawk, In Mission Planner I can see how 3D Fix and GPS data shows up for just a second and then NO GPS message, and after some seconds again 3D Fix, and again NO GPS, and this continues happening always. So, the problem is that having perfect GPS signal, Pixhawk cannot get the GPS data fixed from the Ublox.

What can be the problem? Some configuration? The UBlox is supposed to be set up automatically by the Pixhawk (I´ve got the 3.3 version of Ardupilot) Please help me. I tried several configuration with U-center but problem still exists.

Thank you

PD: Pixhawk controller is not a problem as I used another Ublox before and worked perfectly.


You can send us back the board please. We will test it.
You have just to create a ticket on drotek.freshdesk.com please.
Thanks in advance.

Hi, it turned out to be a problem with the configuration. I set up the Ublox with a GNSS configuration that didn’t work properly. With drotek default configuration file the issue was solved. My guess is that Pixhawk does not auto-configure the Port protocol value when connects to an Ublox if it is wrong set up.

The best is the default configuration and let the Pixhawk configure the Ublox GPS.