Community forums

Pixhawk could not connect to GPS Drotek DP0102 (M8N)

Hello, I recently got DP0102. I tried to connect DP0102 (M8N) to Pixhawk 3 Pro and Pixhawk 4, Unfortunately, No any satellites are acquired (monitor via Qgroundcontrol). That’s very odd.

Furthermore, I changed GPS port from GPS to TELEM1, 2 and other UART. No satellites found. The message I got when entering GPS status shown as attached picture.

I’ve checked this GPS with u-center v19.10 and everything seems to be working fine.

However, my old GPS, “Sirius GPS” and other brand works fine!!

Any help would be appreciated. Thank you so much

I still face this problem. Any advance config via u-Center is needed?

Hi, after digging old docs and articles. I found (guess) that the root of this problem is GPS was not configured properly from factory. so that, I searched for M8N GPS config. file to make it compatible with PX4 firmware and I found this article…

However, I try to manually set GPS (via u-Center) follow this config. file (from attached link). Unfortunately, I still face the same problem, could not connect to Pixhawk (got nothing from GPS). Anyone have a clue or other config. file for M8N to make it compatible with PX4?

PS. This GPS perfectly work with uCenter connect via USB cable but for UART1 (to pixhawk), never work !!

I have tried to reproduce this problem (see PX4 issue), and I can’t seem to configure the GPS module using the UART. It only seems to work over USB.

The PX4 GPS driver tries to configure a uBlox GPS using ubx configure commands. If there are no acks coming back, it gives up.

I wonder if the serial input lines are correctly hooked up to the uBlox module, or if there is software preventing the incoming packets.

1 Like

I contacted Drotek support and got an answer:

M8N devices only have 1 internal UART, however given there are 2 UART outputs on the Drotek module, you need to select which output you’re using.

To do so, you need to make a solder bridge onto the board at the location pointed by the red arrow (see picture) or leave it solder free.

Therefore, if you are willing to use the GPS connected to an autopilot (using the ROVER UART) you need to make a solder bridge on the board (see picture), otherwise leave it solder free and thus the module is using the TELEM UART which has swapped Rx/Tx compared to ROVER UART.

Bear in mind both outputs cannot be used at the same time.

I tried:

  1. Crossing tx/rx (wires 2/3, pin 1 is 5v) and connecting from Pixhawk GPS port to the Gps TELEM port -> works!
  2. Not crossing tx/rx but connecting the solder bridge and connecting from Pixhawk GPS port to the Gps ROVER port -> works!
2 Likes

Works ! ! Thank you so much !!!