Community forums

Problem getting data from Tiny M8P

Hello,
I have a problem of getting reliably data from Drotek Tiny M8P with RTKLIB, more specifically with rtkrcv app.

I’m trying to use M8P on a UAV as a logging unit on Linux machine to consequently use the log for PPK solution. 4 times out of 5 it works just fine and log the data into UBX file, but sometimes the following problem occurs when I start rtkrcv - I would receive 0 of rover satellites and it would never get more satellites/lock until I repower the M8P module. What I found so far:

  • it’s not a signal/antenna problem. The problem appears while keeping the same position with a previously perfect lock.
  • as long is it appears once the only way to solve it is to re-plug the USB cable.
  • when the issue appears, rtkrcv working just fine and keep logging into UBX log file (but of course it’s logging data with no satellites)

Setup:
Linux, Ubuntu 16, rtklib 2.4.3 b31, Tallysman antennas. Settings on Ublx are default, I only tried changing cold/warm start, but it doesn’t solve the issue.
Here is the content of .conf file (taken from Emlid modules) and here is the content of .cmd file, both are used to start rtkrcv.

This is how the output of rtkrcv status look like when the system working correctly - rover and valid satellites exist.
This is the output when the issue appears - zero of rover and valid satellites.


Did anyone encounter a similar problem?
Do you change Ublox default settings?
Could you please confirm that your .conf/.cmd looks similar?

Thank you in advance and I would be thankful for every input!
Cheers!

Hello llia,

First did you try updating the ublox M8P with the latest firmware version ?
This is some kind of issue we never experienced so far.
Did you check on the U-Blox support portal ? There are some topics that might be related to the issue you are talking about, like this one : https://portal.u-blox.com/s/feed/0D52p00008JMPluCAH

Hello Paul,

the firmware was updated to the latest version.
The problem was solved by just removing all the commands from .cmd and after everything worked just fine.

Thank you for your concern!

1 Like