Problem w DROFLY PRO V3 and NEO-7N GPS + HMC5983

Bought both at Drotek and connected the serial2 pins and I2C for the compass at the UBLOX GPS module (both power LEDs are on). Configurated config.h as requested in user guide (MultiWii 2.3DroFlyV1.3), also checked the GPS entries there. By trying uploading I got an compiler error:
GPS.cpp:504:1: error: ‘prog_char’ does not name a type
prog_char UBLOX_INIT] PROGMEM = { // PROGMEM array must be outside any function !!!
^
GPS.cpp: In function ‘void GPS_SerialInit()’:
GPS.cpp:542:29: error: ‘UBLOX_INIT’ was not declared in this scope
for(uint8_t i=0; i<sizeof(UBLOX_INIT); i++) { // send configuration data in UBX protocol

Can’t look into the NEO-7N because it hasn’t a USB port.
Where do I have to make other settings? Can’t find any hints in the guide.

Regards, Thomas

                         ^

The problem is either the Multiwii code or the IDE Multiwii.
Retry to upload the code and recompile please.

Thanks f reply.
Made further checks: GPS is working w preflashed version (checked w. WinGUI).
Tried the compilation (Arduino-SW) w origin Muliwii_2.3_Drofly_V1.3b without changes->I got the same compiler errror as above. Even original MultiWii code produces this compiler errror-
Didn’t made any progress so far.

Maybe a problem with your IDE. What is the version of it?

Hi,
I have Arduino 1.6.3.
After further investigation, I found that the type ‘prog_char’ and ‘char PROGMEM’ are deprecated.
I changed them to simple ‘char’ in the GPS.cpp and it compiles without any error.
Will later check the full functionality on the board and will reply.

check this website: postwarrior.com/arduino-ethershi … me-a-type/

Thomas

Flashed the modifed (config.h) Muliwii_2.3_Drofly_V1.3b software.
Under WinGUI I have the error :
"Navigation code version missmatch. GUI version; v5 ; Controller version: v7 ".

Will look for a GUI v7. The rest seems to be functioning.

Thomas

Tried the WinGUI 2.2 release; all exept the GPS all is working.
This time no GPS data will send. It will indicated as an active sensor, but have no fix.
@DroTek: which preflashed version have you flashed on board and is it pre-configurated. Is it possible to get this as a full functioning (as I have testet on my board) version?

Thomas

you can find the link of the code on the page of product.
You have to enable the good flight controler in the config file.