Proper 3DR Solo RTK Setup

I have been attempting to get DGPS connection between my 3DR Solo and TinyRTK base for several days to no avail. I cannot find a start-to-finish guide on how to accomplish this, so I’ll be as detailed as possible with what I’ve done.

-Installed the 3DR Solo RTK module in Solo
-Updated the base and rover configurations in U-Center as per https://drotek.com/en/lessons/comment-utiliser-le-module-rtk-drotek/
-Downloaded firmware and loaded it onto the Solo using WinSCP as per https://drotek.com/en/lessons/upgrade-your-solo-to-benefit-from-rtk-functionalities/
-Connected TinyRTK base / antenna to my laptop and connected Laptop to SoloLink wifi
-In Mission Planner, connected to the Solo and did RTK inject as per https://drotek.com/en/lessons/drotek-rtk-gps-for-3dr-solo-with-mission-planner/

This is what the output in Mission Planner looked like:

-


I did some reading on this forum and saw talk of uploading ArduCopter 3.5 firmware onto the Solo, so I went to http://firmware.us.ardupilot.org/ and downloaded the most recent V2 .px4 firmware from http://firmware.us.ardupilot.org/Copter/beta/PX4/ (Which so hapoens to be version 3.5 rc7).Installed it on the Solo using WinSCP. Still no connection, and I’m not sure where I would be able to download the ArduCopter 3.5 rc3 .px4 file (which I have read works with Solo). I found the ArduCopter github area where .zip files for different ArduCopter revisions have been placed at http://firmware.us.ardupilot.org/Copter/beta/PX4/, but I cannot find the .px4 files to upload the firmware onto the Solo.

Any help troubleshooting this, or at least to find the .px4 file for ArduCopter 3.5 rc3 would be great, I am at a bit of a loss as to what I am doing wrong.

Hello,

It looks like you are sending corrections the right way, but if you look at your first picture inside Survey-In area it says “Position is not valid”. You are using the following settings :

  • Survey-in accuracy : 2 meters
  • Time : 60 seconds

Remember that both conditions need to be met before the module actually sends differential data. You can try setting a larger accuracy and as soon as your survey-in is valid you should see te DGPS status.

I have some additional questions on this same line. With the above settings I did get the flag to change to green and tell me that it was Surveyed in. It did not give me the DPGS flag in the HUD however. I followed the directions and thought that they were fairly easy to do.

Next question is if Im thinking right. If I have the Survey-in accuracy set to 2 meters does that mean my accuracy will be just 2 meters? The accuracy on the website claims 2.5cm, do I need to change the Survey-in to .025 meters to get to that level? If so how long will the base have to acquire to gain that level of accuracy?

Some users have posted guides in addition to our documentation : What compoments do I need to get RTK for my Solo? and are running it successfully.

There are two things to consider in RTK :

  • absolute accuracy
  • relative accuracy

The latter reflects the positioning precision between your base and your rover. The RTK algorithm is relative, so you will have the 2.5 cm accuracy between your base and your rover.

The former reflects the absolute position, i.e. the GPS coordinates in our global system. To get the absolute position, you are using your base’s position and then “adding the RTK vector” to it. If you have an error on the position of your base, this error will be propagated to the RTK position as a constant offset.

If you need repeatability, the best way is to calculate your base’s position once and then enter it manually without survey-in.

Curious what version of Ardupilot is in the download on your website?

Im getting the XXL to work fine just not getting the dpgs flag in the HUD.

It is a modified version of the last Solo release : https://github.com/3drobotics/ardupilot-solo

See Pull Request #283