Quel firmware Ublox pour le rover? [solved]

Afin de determiner pourquoi Pixhawk 3.4.6 ne configure pas correctement mon M8P employé comme rover et avec la soudure j’ai une question :

Mon Rover est un M8P-02 donc j’ai installé le firmware correspondant, c’est à dire le UBX_M8_301_HPG_130_REFERENCE_NEOM8P2.59a07babb501ba6a89ff87cac2f2765f.bin

Est ce correct oubien devais-je installer le firmware NEOM8P-0 typiquement employé comme rover de sortes que Pixhawk le reconnaisse et le configure correctement ?

Je me réponds tout seul .

Il faut installer le firmware correspondant au modèle de GPS donc pas de firmware du NEOM8P-0 sur le NEOM8P-2

LA version 3.4.6 de Ardupilot ne marche pas avec les M8P il faut le version 3.5

Je confirme, firmware NEOM8P-2 pour NEOM8P2 et firmware NEOM8P-0 pour NEOM8P0. Merci!

Comment déterminer si son unité XL est bien un M8P2 ou un M8P0 ?

J’imagine que les XL sont tous des M8P-0 .

Pour les Tiny il faut regarder sur le circuit intégré

Je peux pas le voir car c’est caché par un shield metallique inamovible. Y-a-t-il moyen via u-center ?

Pas besoin ,tous les XL RTK sont des M8P-2 si j’ai bien compris

Il est possible de voir la version sur U-Center : View -> Messages View -> UBX -> MON -> VER

cool, merci.Ca m’evitera de demonter le RTK XL.