Community forums

RTK2go client connection - does not work

Hi

I am having problems seting up the Ntrip connection in

the Ublox “U-center” software - se picture …

But I get errors and no connection … see log below

Please have a nice weekend.

Best regards - Erik

21:15:40 Data received from server (1023bytes).

21:15:40 Data received from server (1023bytes).

21:15:40 Data received from server (427bytes).

21:15:40 Data received from server (231bytes).

21:15:40 Connection error received (0).

21:15:40 ERROR: Server closed connection.

21:15:40 ERROR: Failure in retrieving correction data.

21:15:41 Sending NMEA request.

21:15:41 Sending request to NTRIP server.

21:15:41 Request sent.

21:15:41 Request thread going to sleep.

21:15:41 Reconnection thread ending current session.

21:15:41 Ending NTRIP session.

21:15:41 Closing connection to server.

21:15:41 Request thread awake.

21:15:41 Server connection closed.

21:15:41 Reconnection thread starting new session.

21:15:41 Start NTRIP session.

21:15:41 Connected to NTRIP server.

21:15:41 Reconnection thread sending last request.

21:15:41 Send mountpoint request (GORLEV)

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (437bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (437bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (725bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (1023bytes).

21:15:42 Data received from server (427bytes).

21:15:43 Data received from server (231bytes).

21:15:43 Connection error received (0).

21:15:43 ERROR: Server closed connection.

21:15:43 ERROR: Failure in retrieving correction data.

21:15:43 Sending NMEA request.

21:15:43 Sending request to NTRIP server.

21:15:43 Request sent.

21:15:43 Request thread going to sleep.

21:15:44 Reconnection thread ending current session.

Hi Erik,

There could be multiple reasons why it does not work.
Did you follow correctly the tutorial provided by RTK2go ? http://www.rtk2go.com/how-to-connect/
Since “u-center” is not one of our product, you may ask to U-Blox directly.

Anyway, do you own “AHRENSBOEK_01” mount point that you chose ? Some of those random mount points don’t send any correction data…
Apparently, you forgot to type in the password which is ‘BETATEST’ until mid 2019.
Did you try with another version of u-center ?

Paul

Hi Paul

Yes - I done the setup as defined. When I ask U-blox they tell me that
you will help me solve the problem …

I think the problem is that in the drop down list in “u-center” all carakters are upper
case - but on the www.rtk2go.com names are both upper case and lower case.

Could you please check and verify this is the problem ?

Best regards, Erik

Hi Erik,

Did you try with any other mount point located near to your place ?
Because if there is an error saying the server has closed the connection, it is probably because the mount point is unstable, or maybe the port is not opened or it could be a rtk2go issue.

I just tried some mount points and it is working very well.
Did you try with the latest 19.05 u-center version ?

Paul

Hi Paul

You server is not working this evening - so I sent you pr. email

Thanks for the feedback. I have now updated to version 19.05. And it does still not work.

In u-center all RTK clients have “upper case” names - but the actual names on the site
are both lower and upper case - RTK2go server staff tells me that the server is case sentative
(upper / lower case) and that is the resaon why it does not work

Here is picture of the server names …

You can se the actual names on this link …

http://rtk2go.com:2101/SNIP::STATUS

Please advice what to do …

BR. Erik

Hi,
I am so sorry Erik, I would like to provide some support but I still do not understand what you are trying to do.
Can you tell me in details, with your own words, what you are willing to do, so that I can give you the best answer ?

Best regards

Paul

Hi Paul

I want to use RTK coorection data from the server rtk2go.

In U-center I type in the adress of the server "rtk2go.com and the port number 2101. See
picture. I then get a list of the “casters” that is possible to connect to on the server.
There is only a pull down list where it is possible to select a “caster” location … All names
are listed in upper case letters …

I try to select one of the “casters” … but it does not work …

When you look at the list of casters at rtk2go.com, you will se that the caster names are both upper
and lower case letters. The staff at RTK2go.com, tells me that the rtk2go.com need to receive requests with the same name ie. both upper and lower case letters. So the problem is the “u-center” only sent
upper case letters … and that is why it does not work …

Please let me know if you need more information…

Please have a nice weekend

Best regards, Erik

Hi Erik,

The UPPER case issue is not one actually. This is how it is written in ‘u-center’.
I managed to get connected to my caster even though it contains lower case.

Do not forget to type in “BETATEST” in the password section, thus leaving the username textbox blank.

Some of the casters I tried are not working. Furthermore, you need to be connected to a caster which is quite close to your actual location, otherwise you will not get precise enough GNSS correction data.

Can you try using other mount points ?

I advise you to make a rtk2go caster (fixed base) using one ZED-F9P and using another one ZED-F9P as a rover connected over rtk2go.

If you previously wanted to be connected to the DROTEK mount point, this not possible anymore in the meantime cause our mount point is currently offline.

Regards,

Paul

FYI The mountPt strings listed in the RTK2go.com NTRIP Caster (like all NTRIP Casters) are case sensitive, and if the case if not correct your NTRIP Client will not be connected. This seems to be a problem with the way recent uCenter software is written. In the past couple of months (since F9 shipment volumes have grown) we are seeing quite a lot of failed connections for uCenter users using upper case when they should not be.

You can read more about the details of mountPt naming in this article: https://www.use-snip.com/kb/knowledge-base/how-to-read-a-mountpt-string/

1 Like

Another post and detail about name mountpoint : http://www.rtk2go.com/how-to-connect/

Hello, I would like to ask some questions regarding naming, which will be very helpful for us when developing ESPrtk to avoid Caster disconnecting our customers:

  • What exactly are the characters allowed by SNIP in the ASCII table set for mountpoint?
    (0123456789abcdefghijklmnopqrstABCDEFGHIJKLMNOPQRSTUVWXYZ_- and …?? )

  • With the characters in the 'allow area of ​​SNIP" , all variants of the mountpoint generated from them are accepted?
    For example: “My_mp_00” and “0_my_MP”.

  • Does SNIP really accept all mounpoint names ? Even obscene words, insults?

  • Is the mountpoint name length limited to SNIP is the same with V1 NTRIP protocol (100 chars) ? If no, what is the maximum mountpoint name length for SNIP?
    -What happens / What will SNIP do when SNIP detects one of the rules for mountpoint names violates the rules that SNIP offers?
    (Will SNIP disconnect without prior notice?)

  • That’s about mountpoint name, What about when users change [Network] and [Misc] (Miscellaneous information) fields in STR string according to their needs? Are there any exceptions?
    For example, is this banned?
    [ESPrtk] …and [Shizuoka University ] for :

STR;SU_RTCM3;Shizudai-Hamamatsu;RTCM3.2;1006(10),1230(10);2;GPS+GLO; ESPrtk ;JPN;34.73;137.72;1;0;sNTRIP;none;N;N;907500; Shizuoka University

Well for those that do not know, SNIP is a commercial NTRIP Caster and RTK2go is simply running a copy of that in a “open” mode such any anyone in the world can mount their own Base Station on it. Many RTK2go users in time download their own copy of SNIP to set up their own network, using either the free model with fewer features or one of the paid models. But this forum is not an advertisement for SNIP sales and most of the answers to your question can be found in the support knowledge base.

But to provide useful quick replies… [soap box on] Read the actual Std from RTCM for the details of what is defined. On top of this SNIP (just like Casters from other makers) implements the meaning of the std and adds some additional value as it see fit. With no disrespect to the other members of the RTCM SC-104 committee, there are things in the adopted NTRIP documents (both Rev1 and Rev2) that can be read (and have been implemented) in various ways. The below answers refer to SNIP.

SNIP allows up to 100 chars (see Clause 6.3 of std) for mountPt name in some connection formats but will not let a user enter more than ~40 chars in various dialogs. There is seldom any need for a long name. In Rev2 the allowed ASCII chars are as you note, there are however few ‘holes’ in Rev1 to deal with. As per the std, any invalid connection attempt for any reason results the Caster table being returned. SNIP also adds some additional debug details when speaking with another SNIP node but this has not yet be considered for wider standardization. Not sure what you mean by ‘prior notice’ in that. Diacritical marks, both in Latin 1 and in other formats, are prohibited. Yes certain rude words are detected, but please bear in mind a rude text string in one language many be inoffensive in another. SNIP IP banning logic can be invoked to prevent such connections when abuse occurs. I do not suggest you try this. If a connecting Base Station (an NTRIP Server) provides a caster table entry, that entry will be used by SNIP if possible. Otherwise SNIP will decode RTCM3 content and create a correct one for the user( this is a major advantage as low end devices increasingly are deployed). SNIP will also test the provided string for validity and reject it if it is obviously wrong. SNIP will also try to strip in the gross city location when not provided. No diacritical marks are used in the Caster entry but these are used in various reports.

Your example to replace the network name with the string " ESPrtk" is a bit nonsensical. The sender determines his network. In the case you mentioned, the University is calling its network “Hamamatsu” and that data is coming from a Trimble NETR9 device. You can see more details with a SNIP command like: http://RTK2go.com:2101/SNIP::MOUNTPT?NAME=SU_RTCM3 (but bear in mind that other SNIP deployments typically choose to disable that command for privacy). Misc data is supported, but is must be short. Using the misc field for advertising is strictly prohibited in RTK2go.

We strongly recommend that people just download their own (free) copy of SNIP if they want to do product and protocol testing. [soap box off]

2 Likes

Thanks for your detailed answer. It will help users who use SNIP / RTK2go to know more about their limitations.
As you said, the [MISC] field is supported, so what is the limit number of characters ?
This is a miscellaneous field, we cannot know what users enter in it.
And the boundaries for them to be banned (or not) are difficult to distinguish for everyone.
The definition of a string of characters (meaning) vulgarity, advertising, limit length, etc. is called " banned characters".
And SNIP will call to auto Banned IP when meeting those characters.
I understand, SNIP do this to create a clean Caster table .
Our ESPrtk also supports the discovery that SNIP returns IP prohibition errors to notify users about their Client / Server reconnecting too many times in a short period of time.
I also know RTK2go will display banned IP lists with unstable connections to remind them to improve internet connection quality when using Caster.

But at the present time, there are too many reasons for SNIP to automatically ban IP.
I want SNIP to have a separate page for banned IPs, listing the most recent connection time, User Agent, show the characters they entered which SNIP thinks it is banned … to notify for more on the reason they banned IP, it will help users know exactly what to do to use SNIP’s free service.

Can confirm, seeing the same issue with u-center as OP when connecting to rtk2go mountpoints with lowercase names. I get stable connections when connecting to mountpoints with all caps names.