Community forums

Tiny RTK Moving Baseline mode won't reach Fixed

Hello, I have a test setup with two Drotek Tiny RTK modules. The Base module is connected from the TELEM port to the TELEM port on the Rover (using a TX/RX crossover cable). Both the Base and Rover have the solid blue LED lit and the green LED flashing. The Rover has the blinking red LED near the TELEM port flashing (I assume this means it’s receiving data from the Base but there isn’t any documentation on this).

Each device is connected to a Tallysman TW4721 antenna separated about 0.5m apart.

I configured the following
Base:
DGNSS: Differential Mode 3
MSG: Output on USB and UART1 - RTCM3 1077, 1087, 1230, 4072.0
RATE: Measurement Period 1000ms, Navigation Rate 1 cycle
TMODE3: disabled
PRT:
UART1: Protocol In: none, Protocol Out: 5-RTCM3, 8N1 at 38400, LSB
USB: Protocol In: 0 + 1 + 5, Protocol Out: 5 - RTCM3

Rover:
DGNSS: Differential Mode 3
MSG: Output on USB - UBX-NAV-PVT, UBX-NAV-RELPOSNED, UBX-NAV-STATUS, UBX-RXM-RTCM
RATE: Measurement Period 1000ms, Navigation Rate 1 cycle
TMODE3: disabled
PRT:
UART1: Protocol In: 5 - RTCM3, Protocol Out: none, 8N1 at 38400, LSB
USB: Protocol In: 0 + 1 + 5, Protocol Out: 0 + 1 + 5

Here is the Data View in u-center. I can’t ever get 3D/GNSS/FIX even in an open field. Headings are garbage.
18%20AM

When I look at UBX-RXM-RTCM it is receiving the RTCM messages correctly.

UBX-NAV-RELPOSNED:

Can anyone help me out? What other config settings or messages should I look at?

Hi dlwalter,

First I suggest you to go back to default settings doing this on both Tiny RTK :

Sans%20titre%201

Then follow our start-up guide to set-up the Tiny RTK as a Base as well as a Rover :
Base : https://drotek.gitbook.io/rtk-positioning-solutions/the-rtk-base/configuring-the-base-manually
Rover : https://drotek.gitbook.io/rtk-positioning-solutions/the-rtk-rover/untitled

In addition, it appears you disabled TMOD3 on the base. Doing so you disabled the RTK solution.
Indeed you must choose between Survey-In or Fixed mode under TMODE3 settings to make RTK works.
On the rover side, there is no need to enable TMODE3 and you can select the disable option.

If you still get some troubles, please send me your Tiny RTK “configuration file” at paul@drotek.com that you can generate from u-center, under “Tools”, “GNSS Configuration…”, then click on “GNSS > File” while your Tiny RTK is plugged-in.

According to the Datasheet at https://www.u-blox.com/sites/default/files/products/documents/u-blox8-M8_ReceiverDescrProtSpec_(UBX-13003221)_Public.pdf#page105

In section 28.3.1 it says that for moving baseline mode TMODE3 on the reference station should be set to “disabled”.

I did end up achieving 3D/DGNSS/FIXED by adding a 10cm x 10cm ground plane to my antennas.

Allright, sorry I did not read carefully that you were using a moving base set-up.
Nice to see you solved your issue by adding a reflective ground plane.

We will certainly make a small tutorial about it in a near future showing performance improvements.

Hello, I found ublox documentation about improving antenna performance and PCB design, hope it helps you all.
https://www.u-blox.com/sites/default/files/products/documents/GPS-Antenna_AppNote_%28GPS-X-08014%29.pdf

1 Like