Tiny RTK with PX4 firmware and QGC dedicated radio

Hi

I am using the tiny RTK with QGC and following the dedicated radio method

Settings are as follows

Base side -
PRT:
Protocol In: none
Protocol out: RTCM3
Baud: 57600

MSG:
UART 1 for RTCM 3.2 1005, 1077, 1087, 1127

Rover side -
PRT:
Protocol In: RTCM3 (like you mentioned)
Protocol out: UBX
Baud: 38400

MSG:
UART 1 for NAV-PPT

RATE @ 5Hz

But when I connect the rover rtk with Pixhawk and connect it to QGC, it doesn’t read !!!

So I tried connecting the 3DR GPS (LEA 6H) to U-center using a FTDI cable and checked its config.

  1. NMEA and NAV messages were activated
  2. PRT : Protocol in: UBX + NMEA + RTCM 2
    Prot. out: UBX, baud: 38400

Like mentioned above, I changed the protocol out and baud of the rover but still same issue !!!
What could be the reason ???

Are you sure that the PRT parameter is updated in the M8P configuration ?

It is not possible on my M8P to change PRT type since Ucenter does not update it when saving.

Are you doing DEDICATED RADIO with QGC and Px4 firmware

I am able to set the PRT and update it as well (screenshot of base and rover attached)
btw, should the base target be selected as USB (if yes, why ??)
What version u-center are you using. does the M8P’s firmware need to be updated ?
Could you list down the params that you set for the base and rover

No, no dedicated radio, I’m using the Mavlink method.
In that case I guess that base need to have PRT parameter set to USB .

I’m using last version of Ucenter .28

It is suggested to update to last version always .

Why do you use two different baurates with a dedicated link ?

Hi

I am making use of the GPS injection with the PX4 firmware an QGC as the dedicated radio method did not work

Using GPS injection and QGround Control,

  1. It is necessary to configure the base or rover ?
  2. Before connecting to QGC, I changed the base TIME MODE 3 to 10 sec time and 10 m accuracy and the Fix mode status on the u center changed to time. With TIME, I connected the drone but it doesnt turn to a FIX mode immediately. After checking teh base params in U center, it has changed to 180 sec and 1 m. Does teh software automatically reset the values (if yes, why ?)
  3. Will the differentials info be sent only to the rover only after survey-in process reaches an accuracy of 1 meter. I suppose the environment too has an impact in completing the survey location ?

Is it possible to do dedicated radio with QGC and px4 firmware

Base baud is at 57600 while the rover is connected to GPS pin whose baud is at 38400

1 With injection method , you have to solder the tabs on Rover module .
In theory then the Rover is configured directly by the flight controller .

I did solder the tabs on the rover
I believe the base need not be configured and

Only after the survey process reaches an accuracy of 1 m will the base start sending out differentials to the rover
Any way to check if the differentials are being transmitted

I believe QGC and PX4 firmware doesn’t support dedicated radio method ?

Arducopter and mission planner supports both gps injection and dedicated radio ?

Correct me if I am wrong

The base need to be configured especially in the MSG parameters and also in TMODE3 , where mode SurveIn must be selected.

To check if RTK datas are transmit go in Message View and look at RTCM3 messages , 1005 , 1077, 1087 shoul not be grayed but bold.

Do not know if QGC and PX4 support or not dedicated radio.

Mission Planner should support both.

Thanks for the info

I did set the RTCM params, TIME MODE 3 for the base

The issue is when I am doing gps inj. thru QGC, I am unable to open the base in u-centre.

When I rechecked the params in u-centre for the base by disconnecting the drone, the have all changed.
Have you faced similar issue ?

You cannot access to the same COM port at the same time so if you are injecting with QGC using the base com port , Ucenter cannot access it.

The telemetry and the base NEO-M8P should have two different COM port .
Not sure to understand what you mean .

The only parameter I’m not able to save on base with Ucenter is PRT .
Did you save the base configuration in CFG after selecting send for each changed parameter ?

The telemetry and the base NEO-M8P do have two different COM ports
and can we monitor the base in u-center when injection is going on.

Did you managed to have the RTK correction with injection method ?

I did not get the fix yet

Just to confirm few things for injection using QGC and PX4 firmware,
1.BASE RTK needs to be set with RTCM messages, PRT settings(as USB) and TIME MODE 3 ?
2. ROVER RTK is controlled by Pixhawk ( needs no parameters to be set) ?
3. I have connected the BASE RTK and drone telem in different com ports but I am unable to access the u-centre software ? How did you do it ?
4. To check if BASE msgs are being transferred to the ROVER, Message View --> RTCM3 messages: 1005 , 1077, 1087 should be bold and not grayed.
5. Any way to confirm if the ROVER is receiving the differential msgs through the base u-center ?

My setup is as follows

Hey

WIth the setup mentioned above

I finally got a RTK FIX
Pics attached


It takes about 20 mins for the survey process to finish and thus change the mode from float and finally fix. Any method to fasten the process ?

Some issues,
1.Unable to access u-center for base along with QGC at the same time though the telemetry and the base NEO-M8P use different COM ports.
2. Unable to set the PRT setting for the BASE NEO-M8P as USB. Does updating the firmware solve the issue ?

  1. ???

  2. No, updating firmware does not solve , but on Ublox forum I was told it was not a problem since at the end it works while if Uart was really used instead of Usb we would cannot connect with base Neo-M8P

Thanks

My first doubt is that when injection is going on thu QGC, could we access the BASE NE0-M8P through u-center ?

You won’t be able to access the USB as it is used by QGC, but you can still access the UART.

Thought so too

Access the UART , how ???

You can use GND, TX and RX from TELEM connector and the use a UART/USB converter like this one : https://drotek.com/shop/en/drotek-parts/65-multiwii-ftdi-arduino-uart-usb.html