u-center unable to connect with my SIRIUS RTK GNSS BASE (F9P)

I cannot get u-center to connect with my SIRIUS RTK GNSS BASE (F9P)

I am running a) u-center 19.06.01 and b) SIRIUS RTK GNSS BASE (F9P)
When I connect my SIRIUS RTK GNSS BASE (F9P) to my Laptop it says ‘USB Device not recognised’
When I look at ‘Device Manager’ I cannot ‘see’ my SIRIUS RTK GNSS BASE (F9P)

Q1. How do I get my Laptop to recognise my SIRIUS RTK GNSS BASE (F9P)?
Q2. How do I check to see if I have the correct drivers?
Q3. Should I start u-center first?
Q4. Should I connect the SIRIUS RTK GNSS BASE (F9P) to my lap top first?
Q5. What is the best thing to do?
Q6. What steps should I take in the correct order?

I would be grateful for any help
Many thanks

Hello Mike,

Indeed, some customers may have troubles with F9P drivers and not especially on our hardware.

First things first, can you try on another computer and check if you get the same issue ?

We noticed the working driver is this one : https://www.u-blox.com/sites/default/files/products/tools/UBX-GNSS-CDC-ACM-windows_Driver_(UBX-drv-v1.2.0.8).exe.zip

Install it, then unplug/replug your device.

If still no luck, can you tell me which version of windows are you running ?

NB: Have a look at here : https://portal.u-blox.com/s/question/0D52p00008HKEFJCA5/c099f9p-windows-81-driver-problems-need-usb-driver-found

Thank you for your help via ‘Team Viewer’ earlier today.
After successfully running for a couple of hours the Fix Mode went from ‘Timed’ to ‘3D’.
Do you know why this happened?
Q1. How do I get the Fix Mode back to ‘Timed’
Many thanks


It has been a pleasure helping you :slight_smile:
On the F9P base, ‘TIME’ means the survey-in process has been successfully completed.
‘3D’ means the solution is having a standard GNSS precision.

I presently have no idea why the system automatically switched from TIME to 3D, nor what it implies on the rover side. I am going to have a closer look at it today and get back to you soon.


Thanks Paul,
Q1. What do these icons mean?
Q2. How do I Read / change them?
Thanks - Mike

Hello Mike,

the 3 first symbols stand for “Hot, Warm and Cold start”. The next 2 are for configuring multiple GNSS device together (not really aware of what is it useful for). The last 3 items with the “gear” are for saving, open and reset the module configuration.

Below a picture from the F9P datasheet showing the differences between cold, hot and warm start. Basically, from testings to testings, the module is able to store the previous coordinates in order to shorten any future survey in time. A cold start means the module will not use these stored coordinates to estimate the actual position, therefore it takes longer to acquire signals.

Thanks again.

I cannot connect to the Rover

It might be my own fault as I may have clicked one of the “Hot, Warm and Cold start” buttons as above.
The SIRIUS RTK GNSS BASE (F9P) seems to be working OK

Could you pleased give me a list of things to try and settings to check?

Many thanks - Mike

No worries. Clicking on these buttons should not be harmful to your items

Can the rover be connected to u-center ?
If yes, click multiple times on image to revert back to default configuration.

Then simply disconnect/reconnect the F9P device, afterwards transfer the rover configuration to your module.

It should be back to normal. If not let met know :slight_smile:

Thanks again Paul.
Q1. How do I “transfer the rover configuration to your module”?
Q2. What is the name of the file?
Q3. What do these files do and where should they be?
Many thanks - Mike

Hello Mike,

A1. You can upload the configuration files to the F9P modules by clicking on the “GNSS configuration…” button under the “Tools” tab.
A2. The name of the files are :
A3. These two files we wrote at Drotek will help you to quickly setup the RTK modules (base + rover) so that you may easily check the RTK system performances using u-center.

DROTEK_F9P_CFG_BASE.TXT must be uploaded into the base module
DROTEK_F9P_CFG_ROVER.TXT must be uploaded into the rover module