Unable to connect in Qground with pixhawk using tiny rtk gps

Hello,
Iam trying to use the rtk gps module with pixhawk , but iam unable to get gps lock in q ground control . I have tried in mission planner I could get gps location there but can not get in Q ground. It shows thats gps satellites available but I am not getting gps lock when using with pixhawk . please help me figure it out

Hello,

Can you post a screenshot with all parameters (HDOP, number of satellites, type of fix, etc…).
Have you soldered the bridge on rover side?

1)I am unable to connect with pixhawk and their is no communication between the devices.
2)I have not soldered the bridge on rover side
3)Is it necessary to solder.if so is it required for both rover and base? …Iam using separate telemetry units for rtk gps as mentioned in the schematic diagram in the doc

There is something I do not understand in your setup :

  • you have connected your base to QGC right?
  • is there an additional radio connected to your base?
  • or are you trying to send differential data through your existing MAVlink connection?
  1. yes the base is connected to qgc
  2. we do have additional radio connected to both base and rover gps
  3. no we are not sending through existing connection…if we can do so…please let us know how… do we proceed doing this
    4)the gps lock is not identified with pixhawk

If you are using PX4 firmware you cannot use a separate radio (without modifying the firmware) for sending differential data, you should encapsulate it through MAVlink, to do so :

  • connect your rover to your autopilot
  • solder the bridge on rover
  • connect your base to QGC with USB
  • use normal telemetry between QGC and your autopilot

Hello Kevin,
I have tried what you have said but could not succeed in getting the gps lock, I have soldered bridge on rover side and connected base to QGC , and connected the rover to PIXHAWK

  1. I get a pop up message showing gps receiver missing
    2)no GPS lock identfied after surveying for more than 20 mins

Your base side looks ok, survey-in is finished.

However, even if you don’t receive differential data TinyRTK behaves as a traditional GPS. THe “GPS RECEIVER MISSING” popup indicates that there is probably a wrong connection. Are you sure of your cable connections? Have you inverted RX and TX?

As for my knowledge I have made the connections right, it seemed to be okay in ardu pilot

  1. I have attached my set up to check the connection
    2)Iam using usb port to connect to QGC so cable should not be an issue as telemetry is through another port
  2. to pix hawak a gps regular gps connection is given
    4)presently communication is happening through usb’s
    5)Main issue is GPS of base is not showing detected after completion of survey , NO GPS lock is identified

yes we have inverted rx and tx in gps connection with pixhawk

Thanks for the images, connections look good so far. Before trying to inject differential stream, do you have a “traditional” lock with GPS? TinyRTK has a fallback to traditional GPS when no differential stream is received. How are the LEDs on TinyRTK?

1)There is no lock shown on gps
2)The LED on Tiny RTK is turned blue , just as in the case pluged in power supply to it
3)LED on PX4 doesnt show gps , still runs in blue

Sorry for the delay, are you still experiencing the problem? Do you have the green LED flashing on TinyRTK when the antenna is connected and outdoors?

yes i do have green LED flashing , but the survey does not get completed even after 45 mins and after around 1 hr.

  1. I have rarely a rtk(float) displayed at my conse after very long time
  2. Can you please tell me how accurate is this rtk in places like INDIA

QGroundControl configures base automatically so that Survey-In runs with the following parameters :

  • accuracy of 1 meter
  • minimum survey time of 3 minutes

Generally and with open-sky conditions, you can reach the 1 meter precision in approximately 15 min, theoretically anywhere on the world (GPS and GLONASS constellations cover the whole planet).

  • Are you subject to Electromagnetic interference?
  • Could you provide a screenshot of the SNR levels when you connect the receivers directly to U-Center?
  • What antennas are you using?