Using all UART ports simultaneously

Hi everyone,

I want to use the Pixhawk 3 Pro with several components that require telemetry ports:

  • Frsky telemetry module
  • Serial connection to a Nvidia Jetson using Mavlink
  • Radio Telemetry Kit provided in the pack

I was able to connect everything in Pixhawk 2: connecting the radio telemetry to TELEM1, Frsky to TELEM2 and the serial connection to SERIAL 4/5. Now, with the Pixhawk 3 Pro I am not able to use TELEM3/4 as the serial port to communicate with Jetson.

I have checked the different parameter options (I am using PX4 with QGroundControl) and I have been able to connect Jetson to the TELEM1 port configuring the port (/dev/ttyS1) in the extras.txt file inside the SD card. The Frsky module has also been correctly configured in the TELEM2 port (/dev/ttyS2).

My problem is that with this configuration I can not use the Radio Telemetry Kit, as it needs to be connected in the TELEM1 port.

Is there any solution to use the TELEM3/4 port for the Mavlink serial connection to use the Telemetry Kit or the Jetson connection?

Which are the devices for this TELEM3/4 port, are they ttyS3 and ttyS4?

Do I need flow control for these functionalities?

Thank you for your help!

Hello, what I would suggest is the following :

  • use TELEM 1 (aka SERIAL 1 or /dev/ttyS1) for the radio telemetry
  • use TELEM 2 for the companion computer (this can be configured as an option in QGroundControl)
  • use TELEM 3 or 4 for the FrSky

I think the easiest way to achieve the FrSky communication is to use a script in the SD card as shown here :

The script would look like : frsky_telemetry start -d /dev/ttyXX

Thank you for your answer Kevin! I also tried this option using the script, and it does not work… In last Pixhawk, /dev/ttyS6 was the Serial 4 port, but I can not find where are the TELEM 3/4 ports located for this new Pixhawk.

I tried “frsky_telemetry start -d /dev/ttyXX” for XX = S3, S4, S5 and S6, and none of them seem to work. Do I need to set some additional parameters for the frsky_telemetry, apart from using this script?

Can you try with /dev/ttyS0? It is linked to SERIAL 3. The numbering does not look consistent with ports.

I have also tried /dev/ttyS0 and it does not work neither for my mavlink connection nor Frsky telemetry (my wires are using the S4 TX/RX ports, which should be the SERIAL 4 device?). Where can I check the /dev/ttySX links to SERIAL ports for this Pixhawk version?

Thank you for your help!

I am not sure about the numbering order I’ll have a look at the code. Have you specifically tried /dev/ttyS0 with SERIAL 3?

I’m in the same case.
I need 3 telemetries : frsky, 433 Mhz radio, 5 Ghz radio.
Each is working perfectly when plugged in TELEM 1 or 2, but never works with TELEM 3/4 !
I’m using AC 3.5.6 and QGC.

Have this problem been solved ?